Sass editor incorrectly reporting a syntax error when nesting a descendant selector

Problem: syntax error is incorrectly being shown when nesting a descendant selector

Product / version: Rubymine 2.5 EAP 97.39.

Test case:

.mod-std {
    @extend .std;
    > .hd {
        margin: o;
    }
}

What is the expected output? What do you see instead?
The editor should validate the syntax as being ok. Instead the editor thinks there is a syntax problem at the end of the second line, showing the message: '}' expected

2 comments

Hello,

Thanks a lot for reporting this, could you please file an issue in RubyMine's bugtracker at:http://youtrack.jetbrains.net/issues/RUBY
In this case you'll get notified once it's fixed.

Best regards,
Oleg

0

Please sign in to leave a comment.