Request default behavior change listing generators

Using RM EAP 96.1146

When openning Tools > Run Rails Generator..., default to show the full list.

Problem Scenario:
I was just starting a new Rails 3 app (my first) and after getting my gems installed and attached, I reloaded the rake tasks. I couldn't find the option to reload the generators. I openned the Tools > Run Rails Generator... and am greeted with an empty edit box. I type single letters and get some options, but it's just trial and error. I don't know how to make it reload the generators either.

After playing, I typed a "*" and it wild-card filtered on ALL and I was able to see an option to reload the generators. Which didn't come up when I typed "reload" for some reason.

So please change the default behavior to auto-display all. Otherwise new users will be completely lost. I'm not new and I was lost for a bit there too.

Thanks,
-Mark E.

Please sign in to leave a comment.