Problem with light-bulb on top line (EAP 96.1146)

Hi Folks

I have noticed that if I have some notifiable condition on the top line of the file I am editing, the notification icon (light bulb) appears above the editor and I lose keyboard focus.
The easiest way to reproduce this is to have an incorrectly spelled word in the top line and put the caret on that word.

I am running EAP 96.1146 on Ubuntu 10.04 64 bit, JDK 1.6.0_20.

Anybody else notice this behaviour ?

Regards, Tony

7 comments

Hello Tony,

I've just tried to reproduce it on the exactly same configuration and I didn't managed.
Do you use 32bit or 64bit JDK?

Regards,
Oleg

0

Hi Oleg

I am not sure what JDK version I am using on my work machine but I have just checked the same behaviour on my home machine.

Ubuntu 10.04 32bit

java -version reports the following:
java version "1.6.0_20"
Java(TM) SE Runtime Environment (build 1.6.0_20-b02)
Java HotSpot(TM) Server VM (build 16.3-b01, mixed mode)

The only plugin I have loaded in the IDEA server.

I am not sure what else might be different in my setup.

Any suggestions ?

Regards, Tony

0

What kind of file was you editing? Does it matter? What kind of bulb do you get: red or yellow?

Regards,
Oleg

0

Hi Oleg

I created a simple text file with a spelling error on the first line.
The screenshot shows the resulting (yellow) light-bulb.
Selection_003.png

Not sure if this sheds any light (excuse the pun :-)

Regards, Tony

0

Just a thought: what Look & Feel do you use? Can you constantly reproduce it using different L&F?

0

Hi Oleg

Good suggestion.

It definitely seems to be L&F related.
These are the results I got for the L&Fs on my machine:

Alloy. Acid Theme - ok
Alloy. Bedoin Theme - ok
Alloy. Default Theme - ok
Alloy. Glass Theme - ok
CDE/Motif - ok
GTK+ - ok
IDEA (4.5 default) - fail
JGoodies Plastic - ok
JGoodies Plastic 3D - ok
JGoodies Plastic XP - ok
JGoodies Plastic LF - can't set
Metal - fail
Nimbus - ok and fail !


The interesting one is Nimbus.
If I use Nimbus from a fresh start of RM it fails.
If I toggle to a working L&F (for example GTK+) then back to Nimbus it works fine.

Others may have this weirdness but I did not check all combinations.

Not sure if this helps you but at least I now have a work-around :-)

Thanks for your help.

Regards, Tony

0

Thanks for reporting this. At least we'll be aware of such a problem.

Best regards,
Oleg

0

Please sign in to leave a comment.