Нэ дэбажить

Скачав. Поставыв. Чуть нэ стэр существующий рельсопроект (ааааа...)
Наставыв брекпойнтив.

И шо???

А йий (Рубимайни) -- эбсолютли до лампочки.

Не, -- ну тоесть вообще. Мынае брекпойнты с якоюто невероятною, просто касмическою скоростью, ще й лыбыця по дорози.
Тоесть нема даже намёка на то, шо вона хоть якось там, чисто по приколу ну хоть бе чуточку прытормозыла -- фигушки.

А так, вообще то у вас така идешка ничо получилась.

Куда покруче всяких вонючих нетбинсов и, особенно, крайне тупорылойи, смраднойи аптаны (радрайлс, чи як йийи там)

Ну такое вот.

Як научить РубиМайночку, шо брекпойт есть свята корова, коло которой надо резко встать як укопаной и три раза сказать "Чу! Чу! -- Я креведко!"

З уважением,
вечно ваш навеки,
лучшайший прогер в мире (як не бильше)
Юр4ег
//да да, -- джемы стоять.
//читав читав форум -- ничо вменяемого ((
//и хелп читав тоже.

12 comments

Здрастуйте шановний!

Дуже дякуемо за тепли слова, усиею камандою, единогласно.
Також мусим сказать, шо Рубимайн дебажить, ще й як! Але за цим перейду на англицку бо так тут прынято.

We need to clarify some details before we can propose any solutions: What's your OS? And what's your environment in more details?

Also try to activate Debugger verbose output in Settings | Debugger  panel and send us the output after another debugging attempt.

-Eugene

0

за це время пока вы там чехлытэсь я тут замутыв такэ:

-Druby.debug.output=true

кудато сюда rubymine.exe.vmoptions

ну и началысь нови приколы (ща попробую картинку подмутыть)



Attachment(s):
aga, connect blia, schas zhe.PNG
0

О!!!!! есть рэспонс!!!!
Ани жывы!

Здорово)

счас схожу по папироски, прыйду и всо попробую.

//создаеться якето муторне впечатление, шо я вам таки соточку баксов за эту идешку таки да, отстегну.
//вместо того шоб як всегда пойты на торенты и скачать уже крэкнуту

Пока никуда не тикайтэ,
щас буду

Ю.

0

English... again...

So my OS is fn XP with some SP.

Environment? Whut do ya mean?

Ruby 1.8.7 Rails 2.3.8


gems

actionmailer (2.3.8, 2.3.4)
actionpack (2.3.8, 2.3.4)
activerecord (2.3.8, 2.3.4)
activeresource (2.3.8, 2.3.4)
activesupport (2.3.8, 2.3.4)
authlogic (2.1.6, 2.1.5)
cgi_multipart_eof_fix (2.5.0)
columnize (0.3.1)
configuration (1.1.0)
declarative_authorization (0.4.1)
devise (1.0.8)
factory_girl (1.3.1)
faker (0.3.1)
fastthread (1.0.1 i386-mswin32)
gem_plugin (0.2.3)
git (1.2.5)
haml (3.0.12)
heroku (1.9.13)
high_voltage (0.9.0)
hoe (2.6.1)
jrails (0.6.0)
json_pure (1.4.3)
launchy (0.3.7)
linecache (0.43 mswin32)
mime-types (1.16)
mongrel (1.1.5 x86-mingw32)
mysql (2.8.1 x86-mingw32)
paperclip (2.3.3)
rack (1.1.0, 1.0.1)
rails (2.3.8, 2.3.4)
rake (0.8.7)
rest-client (1.4.2)
rspec (1.3.0)
rspec-rails (1.3.2)
ruby-debug (0.10.3)
ruby-debug-base (0.10.3 mswin32)
ruby-debug-ide (0.4.5)
ruby_parser (2.0.4)
rubyforge (2.0.4)
sequel (3.13.0)
sexp_processor (3.0.4)
sinatra (1.0)
sqlite3-ruby (1.2.1 mswin32)
taps (0.3.11)
test-unit (1.2.3)
warden (0.10.7)



RubyMine 2.0.2

Trying to debug Rails application
0

Please update ruby-debug-base and ruby-debug-ide gems and try again

0

Денис,
could you be as kind as to tell me what специфик versions of the mentioned gems are appropriate for (best in the industry IDE) RubyMine?

Just before the posting I have updated all the gems via
gem update ruby-debug
gem update ruby-debug-base
gem update ruby-debug-ide

actually it said "nothing to update" every time

I listed gems again:

gem list
....

ruby-debug (0.10.3)
ruby-debug-base (0.10.3 mswin32)
ruby-debug-ide (0.4.5)
ruby_parser (2.0.4)
....



Энд стилл -- як нэ деюажыла так и дальше не хоче (

P.S.: Another prob was from the very beginning of installation -- RM didn't even start complaining "JVM couldn't start". I've read the forum and found solution about decreasing memory assigned to JVM. You know guys, you better avoid stuff like "didn't start from the beginning" because I didn't kick RM out only for solely reason that I already hate Aptana RadRails (even fast 3rd version) and NetBeans (6.5)
It is quite koniu poniatno that application with the default settings should be useful out of the box. Or there should be clean "trouble shouting" document.
0

You may simply uninstall ruby-debug-ide and ruby-debug-base gems and when you start debugging RubyMine will suggest to install bundled version, which is 0.4.9.
Whan system are you on? I can see that ruby-debug-base is with mswin32 platform, so it should be Windows, but what version? Also, how much memory do you have?

0

Задебажыла тварюка)
Ща отдельным тредом раскажу як.

От тока шо )
)))))))))

ААаааААаааАааааааааааааа!!!

ПАШЕ!!!!!

0

Thanks a lot for posting your workaround!

Best regards,
Oleg

0

still, RubyMine debugging works significantly worse then in NetBeans with ruby 1.9.2 and rails 3.0 (though there I need to run rdebug-ide in console and then attach it to Netbeans because Netbeans runs it in Rails 2 way). but after attaching it works great. In Rubymine, meanwhile, debugger is disconnects time from time and freezes. so I think it's definitely problem of RubyMine rather than debug-ide gems, etc.

I hope that it's problem of dev version of rubymine 2.5, and in stable version it will work great.
Besides of this, I like RubyMine more and more.Great work!

0

Please sign in to leave a comment.