Is Not Debugging [SOLVED!]

So you've installed it and it ignores the brakpoints.

First of all put this line:
-Druby.debug.output=true
into your rubymine.vmoptions, it is in [bin] folder

Try to debug. If you're getting popup window like one I've attached here, your problem is with gems, RM needs to perform debugging.

Do this:

1) Find a "DevKit", I've found it here:
http://rubyforge.org/frs/download.php/62353/devkit-3.4.5r3-20090411.7z

actually there is entire article, which I didn't read too carefully, but maybe you should (I've just took a devkit link from there)

Download and install it following the instructions in Install file (copy all stuff to Ruby installation folder + update devkit\msys\1.0.11\etc\fstab file to reflect your ruby installation paths)

2) Go to your ruby installation then \lib\ruby\gems\1.8\gems
and kick ass of these 3:

ruby-debug

ruby-debug-base

ruby-debug-ide

3) Now install them like usual:

gem install ruby-debug

gem install ruby-debug-base

gem install ruby-debug-ide

If you did all things right way, there should be no installation errors. You must see message "1 gem installed" after each install (This is why we needed devkit, those gems are "native extensions" or something alike)

4) gem list
You should see the following
...

ruby-debug (0.10.3)
ruby-debug-base (0.10.3 mswin32)
ruby-debug-ide (0.4.10, 0.4.9, 0.4.5)
...

(ok, ok I have 3 versions of ruby-debug-ide because of two days fighting it))) you need the last one. probably.)

5) Now, if you're coming out of English world, (Ukraine, Russia etc) -- RM will not debug if you're having non ASCII characters in your application path. Like in my case = I've got some cyrillic characters there.
=Remove it! Rename to plain ASCII, probably spaces should be wiped too.

AND

V * o * i * l * a

works like a charm)



Attachment(s):
aga, connect blia, schas zhe.PNG
2 comments

HEY! would some moderator proofread the subject for
-s
+d

?

thanks

0

Hello de Veloper,

Thanks a lot for this solution! The only thing I have to add, that RubyMine 2.5 EAP builds have an option File | Settings | Debugger | Ruby | Verbose debugger output instead of adding

-Druby.debug.output=true
into your rubymine.vmoptions.



Best regards,
Oleg
0

Please sign in to leave a comment.