weird bug with java (rubymine works slowly and consume full ram)

Hi, until yesterday I was working well with rubymine but today when I open it, It take almost 10 minutes for run, when run it delete all my profile (my live templates, preferences, configurations, etc)...I have'n touch nothing with java or amended something inside java neither...I use java 1.6 (no openjava) when I type rpm -qa | grep java i get this

java-1.6.0-sun-plugin-1.6.0.20-0.1mdv2010.0
java-1.6.0-sun-alsa-1.6.0.20-0.1mdv2010.0
java-1.6.0-sun-1.6.0.20-0.1mdv2010.0
java-1.6.0-sun-devel-1.6.0.20-0.1mdv2010.0
java-1.6.0-sun-fonts-1.6.0.20-0.1mdv2010.0
java-1.6.0-sun-jdbc-1.6.0.20-0.1mdv2010.0
java-1.6.0-sun-src-1.6.0.20-0.1mdv2010.0

I try the patch export JDK_HOME=/usr/lib/jvm/java-1.6.0  and don't work neither...

the first time than I had the problem, inside my terminal I get:

[root@localhost bin]$ ./rubymine.sh
23-jul-2010 19:25:27 java.util.prefs.FileSystemPreferences$2 run
INFO: Created user preferences directory.
23-jul-2010 19:25:27 java.util.prefs.FileSystemPreferences$7 run
ADVERTENCIA: Prefs file removed in background /home/yo/.java/.userPrefs/prefs.xml
Warning:  The encoding 'UTF-8' is not supported by the Java runtime.



I uninstall java 1.6 and reinstall it (and java  development)...now when I run RM don't appear this message but this keep buggie and slow (without open projects RM consume almost 490 mb!!)..what happen and what can I do?...thanks

2 comments
Comment actions Permalink

Hi Adrian,

We've been already reported about perfomance problems in latest build. Most likely it is JavaScript related.
Could you please attach CPU snapshot as described here: http://devnet.jetbrains.net/docs/DOC-1144


Best regards,
Oleg

0
Comment actions Permalink

sorry Oleg but I ca't do that, I reinstall RM and the problem seem was resolved, if I've this problem again I will report it but for now seem reinstall RM solved my problem

0

Please sign in to leave a comment.