IronRuby and RubyMine 2.0.2 - Can it really work?

I have tried postings I found Googling and while I can get RM to recognize IronRuby as an SDK, it is not working very well for me.  One of my key issues and I think there are more, I see an error stating that rubygems is not installed.  So, RM is invoking something in IronRuby, or loading some library that is trying to require rubygems I suspect, but fails.

Now, when I go play with IronRuby at command line, I can use its gems command.  I even installed HttpParty.

I also searched this forum and found lots of other issues with IR and RM.  So IntelliJ, IntelliJ Community.... what is the correct, working recipe for IR in RM?  Is this just plain daft and not going to work?  I am in a shiop with some MS bigots and am trying to use Ruby as a scripting tool for support work.  My best shot is probably IR.  It is what it is.  Any help is appreciated.

Thanks

1 comment
Comment actions Permalink

Hello John,

We didn't tested RM with IronRuby and RM doesn't provide some specific support of IronRuby features. RM knows that IronRuby use "ir" interpreter and tries to work with it as with MRI Ruby. If our users actively vote for IR support we will improve/fix/add it. At current moment IR support isn't a high priority feature and we are working on other requests. All  feature requests / feedback are welcome!

P.S: By the way which is your OS? Windows or Mac/Linux?

0

Please sign in to leave a comment.