Debug error when upgrading to RubyMine 2.0.2 - Fixed

Hey,

*running OSX*

I just upgraded to 2.0.2 and when I hit debug to test my new wicked code, i was getting the following error (also included in the screenshot below)

Cannot connect to the debugged process at port XXXXX in 10s


Error output:
/LIbrary/Ruby/Gems/1.8/gems/ruby-debug-ide-0.4.4/bin/rdebug-ide:21: uninitialized constant Debugger (NameError)

To fix this, I needed to upgrade to the latest version of ruby-debug-ide.

To uninstall ruby-debug-ide:

sudo gem uninstall ruby-debug-ide

To install the 0.4.9

sudo gem install ruby-debug-ide --version 0.4.9


Then it worked.


Attachment(s):
Picture 6.png

Please sign in to leave a comment.