ruby 1.9 - debugger crashes while running rspec test

Hi Folks,

Get the following error

Uncaught exception: superclass mismatch for class RemoteInterface
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/ruby-debug19-0.11.6/cli/ruby-debug/interface.rb:128:in `<module:Debugger>': superclass mismatch for class RemoteInterface (TypeError)
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/ruby-debug19-0.11.6/cli/ruby-debug/interface.rb:1:in `<top (required)>'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:158:in `require'
from <internal:prelude>:34:in `require_relative'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/ruby-debug19-0.11.6/cli/ruby-debug/processor.rb:1:in `<top (required)>'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:158:in `require'


...

There is also a related ticket filed by another user
http://youtrack.jetbrains.net/issue/RUBY-5782

I have attached full details. I am trying to migrate to ruby 1.9 but having no ability to debug sucks :(. Is there any solution to this problem?

Thanks,
Parag
--------------------------------------

OS = OSX - Snow Lepord

rubymine = 2.0.2 EA (I had the same error in 2.0.1 also)

ruby = ruby 1.9.1p378 (2010-01-10 revision 26273) [i386-darwin10.2.0]


Gem List:

actionmailer (2.3.5)
actionpack (2.3.5)
activerecord (2.3.5)
activeresource (2.3.5)
activesupport (2.3.5)
archive-tar-minitar (0.5.2)
builder (2.1.2)
columnize (0.3.1)
cucumber (0.6.3)
diff-lcs (1.1.2)
factory_girl (1.2.3)
faker (0.3.1)
gemcutter (0.5.0)
hoe (2.5.0)
json_pure (1.2.3)
linecache19 (0.5.11)
mysql (2.8.1)
nokogiri (1.4.1)
polyglot (0.3.0)
rack (1.1.0, 1.0.1)
rack-test (0.5.3)
rails (2.3.5)
rake (0.8.7)
remarkable (3.1.13)
remarkable_activerecord (3.1.13)
remarkable_rails (3.1.13)
rspec (1.3.0)
rspec-rails (1.3.2)
ruby-debug-base19 (0.11.23)
ruby-debug-ide19 (0.4.12)
ruby-debug19 (0.11.6)
ruby_core_source (0.1.4)
rubyforge (2.0.4)
rubygems-update (1.3.6)
sqlite3-ruby (1.2.5)
term-ansicolor (1.0.5)
test-unit (1.2.3)
treetop (1.4.4)
webrat (0.7.0)
ZenTest (4.2.1)


Full Stack Trace =


/Users/pbajaria/.rvm/rubies/ruby-1.9.1-p378/bin/ruby -e STDOUT.sync=true;STDERR.sync=true;load($0=ARGV.shift) /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/bin/rdebug-ide --port 53866 -- /Users/pbajaria/Documents/git/wh_netbeans/script/spec /Users/pbajaria/Documents/git/wh_netbeans/spec/controller/fbuser_controller_spec.rb --require teamcity/spec/runner/formatter/teamcity/formatter --format Spec::Runner::Formatter::TeamcityFormatter:matrix --example For FbuserController for an authenticated user  when I perform GET 'fbuser/profile' then it should return the profile of friend if the friends id has been specified
Testing started at 2:58 PM ...
Fast Debugger (ruby-debug-ide 0.4.9) listens on :53866
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/rails-2.3.5/lib/rails/gem_dependency.rb:119:Warning: Gem::Dependency#version_requirements is deprecated and will be removed on or after August 2010.  Use #requirement
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/ruby-debug19-0.11.6/cli/ruby-debug/interface.rb:128:in `<module:Debugger>'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/ruby-debug19-0.11.6/cli/ruby-debug/interface.rb:1:in `<top (required)>'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:158:in `require'
<internal:prelude>:34:in `require_relative'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/ruby-debug19-0.11.6/cli/ruby-debug/processor.rb:1:in `<top (required)>'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:158:in `require'
<internal:prelude>:34:in `require_relative'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/ruby-debug19-0.11.6/cli/ruby-debug.rb:6:in `<top (required)>'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:158:in `require'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/core_ext/kernel/requires.rb:7:in `block in require_library_or_gem'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/core_ext/kernel/reporting.rb:11:in `silence_warnings'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/core_ext/kernel/requires.rb:5:in `require_library_or_gem'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/rails-2.3.5/lib/test_help.rb:30:in `<top (required)>'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:158:in `require'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/rspec-rails-1.3.2/lib/spec/rails/extensions/spec/runner/configuration.rb:2:in `<top (required)>'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:158:in `require'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/rspec-rails-1.3.2/lib/spec/rails/extensions.rb:3:in `<top (required)>'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:158:in `require'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/rspec-rails-1.3.2/lib/spec/rails.rb:18:in `<top (required)>'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:158:in `require'
/Users/pbajaria/Documents/git/wh_netbeans/spec/spec_helper.rb:6:in `<top (required)>'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:158:in `require'
/Users/pbajaria/Documents/git/wh_netbeans/spec/controller/fbuser_controller_spec.rb:1:in `<top (required)>'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:147:in `load'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:147:in `load_with_new_constant_marking'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/rspec-1.3.0/lib/spec/runner/example_group_runner.rb:15:in `block in load_files'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/rspec-1.3.0/lib/spec/runner/example_group_runner.rb:14:in `each'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/rspec-1.3.0/lib/spec/runner/example_group_runner.rb:14:in `load_files'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/rspec-1.3.0/lib/spec/runner/options.rb:133:in `run_examples'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/rspec-1.3.0/lib/spec/runner/command_line.rb:9:in `run'
/Users/pbajaria/Documents/git/wh_netbeans/script/spec:10:in `<top (required)>'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/ruby-debug-ide19-0.4.12/lib/ruby-debug-ide.rb:123:in `debug_load'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/ruby-debug-ide19-0.4.12/lib/ruby-debug-ide.rb:123:in `debug_program'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/ruby-debug-ide19-0.4.12/bin/rdebug-ide:87:in `<top (required)>'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/bin/rdebug-ide:19:in `load'
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/bin/rdebug-ide:19:in `<top (required)>'
-e:1:in `load'
-e:1:in `<main>'
Uncaught exception: superclass mismatch for class RemoteInterface
/Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/ruby-debug19-0.11.6/cli/ruby-debug/interface.rb:128:in `<module:Debugger>': superclass mismatch for class RemoteInterface (TypeError)
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/ruby-debug19-0.11.6/cli/ruby-debug/interface.rb:1:in `<top (required)>'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:158:in `require'
from <internal:prelude>:34:in `require_relative'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/ruby-debug19-0.11.6/cli/ruby-debug/processor.rb:1:in `<top (required)>'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:158:in `require'
from <internal:prelude>:34:in `require_relative'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/ruby-debug19-0.11.6/cli/ruby-debug.rb:6:in `<top (required)>'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:158:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/core_ext/kernel/requires.rb:7:in `block in require_library_or_gem'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/core_ext/kernel/reporting.rb:11:in `silence_warnings'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/core_ext/kernel/requires.rb:5:in `require_library_or_gem'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/rails-2.3.5/lib/test_help.rb:30:in `<top (required)>'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:158:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/rspec-rails-1.3.2/lib/spec/rails/extensions/spec/runner/configuration.rb:2:in `<top (required)>'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:158:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/rspec-rails-1.3.2/lib/spec/rails/extensions.rb:3:in `<top (required)>'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:158:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/rspec-rails-1.3.2/lib/spec/rails.rb:18:in `<top (required)>'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:158:in `require'
from /Users/pbajaria/Documents/git/wh_netbeans/spec/spec_helper.rb:6:in `<top (required)>'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/polyglot-0.3.0/lib/polyglot.rb:65:in `require'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:158:in `require'
from /Users/pbajaria/Documents/git/wh_netbeans/spec/controller/fbuser_controller_spec.rb:1:in `<top (required)>'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:147:in `load'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:147:in `load_with_new_constant_marking'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/rspec-1.3.0/lib/spec/runner/example_group_runner.rb:15:in `block in load_files'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/rspec-1.3.0/lib/spec/runner/example_group_runner.rb:14:in `each'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/rspec-1.3.0/lib/spec/runner/example_group_runner.rb:14:in `load_files'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/rspec-1.3.0/lib/spec/runner/options.rb:133:in `run_examples'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/rspec-1.3.0/lib/spec/runner.rb:61:in `run'
from /Users/pbajaria/.rvm/gems/ruby-1.9.1-p378/gems/rspec-1.3.0/lib/spec/runner.rb:45:in `block in autorun'
Empty test suite.


Process finished with exit code 1

1 comment

Hi Parag,

Thanks for providing details.
I have a question for you, have you tried to debug tests from command line? Do you get into the same problem?
Most likely it is a problem of ruby-debug itself rather than rubymine's.
Please vote for the related issue.

Regards,
Oleg

0

Please sign in to leave a comment.