Inspection errors in gutter without reason

Hello,

I've got a lot of inspection errors in the right gutter and actually don't know why...

The number of errors shown in the summary tooltip at the top of the inspection gutter differs seriously from the errors shown below. When I hover the mouse over the error dashes, no tooltip appears at most of them.
RubyMine1.png
After switching off all inspection, the analysis summary of the file is green, but still a lot of errors below.

RubyMine2.png


What can I do to get rid of the false inspection errors?

Regards, Uwe

7 comments
Comment actions Permalink

For some reasons I cannot see your images neither in Firefox nor in Google chrome. Can you see them by yourself?

Regards,
Oleg

0
Comment actions Permalink

No, I couldn't see them either. I just re-uploaded the images.

Regards, Uwe

0
Comment actions Permalink

Thanks for the issue, it seems that it is similar to http://youtrack.jetbrains.net/issue/IDEA-26230
Feel free to comment and vote for it!
It would be very helpful if you provide some instruction how to reproduce it (maybe some test project).

Regards,
Oleg

0
Comment actions Permalink

Thanks, I prepared a small test project, take a look at the counties_controller.rb

I currently cannot access YouTrack, so I attached the sample to this message.

Regards,
Uwe



Attachment(s):
inspections.zip
0
Comment actions Permalink

Thanks for the sample project,  we will have a look soon.

Regards,
Oleg

0
Comment actions Permalink

I deleted the .idea directory and reopened the project in RubyMine. That helped.

Regards,
Uwe

0
Comment actions Permalink

Thanks for reporting this and happy new year!

0

Please sign in to leave a comment.