Line separator does not match project line separator

Since upgrading to 2.0 I frequently see the following error message when I try to commit changes. It happens on a fairly regular basis, it's farily annoying, and I never saw in 1.1:

The following text files have line separator that do not match the project line separator. Select files you wish to convert to project default line separators before commit.

It then lists some of the files I've been editing. The (button) options for the dialog box displaying this mesage are: Convert Selected, Leave Unchanged, and Cancel.

I'm just editing files. Can anyone tell me why this is happening and what option I should choose when it does?

Thanks,
Larry

Please sign in to leave a comment.