Plugins: Version numbering?

Hi,
I'd like to support RubyMine 2.0 with the next update of the BashSupport  plugin.
I've already asked in the intellij-eap forum several times, no reply there, though.

I can't figure out which since-build I have to use to make it compatible with RubyMine.

I tried "10000", "RM-90", "RM-91.15", "IC-90.0", etc.
According to the IC source code of BuildNumber all these should be valid.

Which numbering can I use?
The optimal solution would be a since-build compatible with all editions (IC, IU and RM).

Best regards,
Wallaby

8 comments
Comment actions Permalink

Hi Wallaby,

As far as RubyMine is built on the top of IntellIJ Platfrom it uses the common versioning policy. Look for details at: http://www.jetbrains.net/confluence/display/IDEADEV/Build+Number+Ranges

Thus you can use the following for since-build restriction:
<idea-version since-build="91.15"/>

Regards,
Oleg

0
Comment actions Permalink

Hello,

Also please don't forget to add "Platform Dependency" in your plugin.xml :

<depends>com.intellij.modules.lang</depends>


This fake dependency allows to use your plugin with all IntelliJ Platform products (IDEA, RubyMine, WebIDE, MPS, etc.)
0
Comment actions Permalink

Hi Oleg,
thanks for the reply!

I tried to use this in the plugin.xml:

    <idea-version since-build="91.15"/>
    <depends>com.intellij.modules.lang</depends>

But this does not work, it marked the plugin as incompatible in the plugin settings (highlighted as red).
This works in IntelliJ IU 92.56, though.

In RubyMine, if I remove the idea-version tag and just use
    <depends>com.intellij.modules.lang</depends>
it works!
But the plugin is not compatible with 8.x, so I have to have a since-build value.

Is there a fix for this?

Regards,
Wallaby

0
Comment actions Permalink

Is your plugin available somewhere? I can download it and try to play with since/until tags

0
Comment actions Permalink

We've fixed a bug related to new build format in plugin manager of RubyMine (and other IntelliJ platform based IDEs). Fix will be available with RubyMine 2.0 bug fix update.

0
Comment actions Permalink

Hi,
if you still like to experiment there's a new version (0.9.6-maia) available at http://plugins.jetbrains.com/plugin/?idea&id=4230 .
If you manually remove the idea-version it's supposed to work with RubyMine 2.0 .

Best regards,
Wallaby

0
Comment actions Permalink

Hi,
I check with the latest 2.0.1 build (93.22) and the plugin is still not available.
If I unzip manually it is still shown as red plugin, i.e. it's disabled (for unknown reasons). It's supposed to work with all builds later than 91.15.

Tested plugin: BashSupport 0.9.6-maia (http://plugins.intellij.net/plugin/?id=4230).

Is there something wrong with the setup or is there a way to workaround the problem?

Best regards,
Wallaby

0
Comment actions Permalink

Hello Wallaby,

This problem will actually be fixed in 2.0.1 final. 2.0.1 RC and older builds
don't use the correct build number for plugin compatibility checks.

I check with the latest 2.0.1 build (93.22) and the plugin is still
not available.

If I unzip manually it is still shown as red plugin, i.e. it's
disabled (for unknown reasons). It's supposed to work with all builds
later than 91.15.

Tested plugin: BashSupport 0.9.6-maia
(http://plugins.intellij.net/plugin/?id=4230).

Is there something wrong with the setup or is there a way to
workaround the problem?


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Please sign in to leave a comment.