Unable to install ruby-debug-ide on RubyMine 2.0: Windows with Ruby 1.8.7

Hi,

I've got a problem on my current RubyMine installation:


OS: Windows 7
RubyMine:2.0 RM 91-15
Ruby: 1.8.7

When I want to debug, RubyMine ask me to install ruby-debug-ide.
After OK and some secounds the following happens:

Error-Code:
Failed to install gems. Following gems were not installed:
ruby-debug-ide:  Error installing ruby-debug-ide:
ERROR: Failed to build gem native extension.  C:/Ruby/1.8.7/bin/ruby.exe mkrf_conf.rb Building native extensions.  This could take a while...   Gem files will remain installed in C:/Ruby/1.8.7/lib/ruby/gems/1.8/gems/ruby-debug-ide-0.4.9 for inspection. Results logged to C:/Ruby/1.8.7/lib/ruby/gems/1.8/gems/ruby-debug-ide-0.4.9/ext/gem_make.out Building native extensions.  This could take a while...

Can you help me?
Greetings
Wolfram

4 comments
Comment actions Permalink

Ok,

that's my workaround (that seems to work).

I have installed ruby 1.9 and the ruby-debug-ide19  (follow the manual) --- and it works.

Then I've changed back to 1.8.7 --- and ruby-debug-ide can be installed without an difficulty.

That' all folks
Wolfram

0
Comment actions Permalink

I have the same problem with Ruby 1.9.1 on Windows Vista x64. When I try to install ruby-debug-ide19, I get this error

Error running sassator: Failed to install gems. Following gems were not installed:

ruby-debug-ide19:  Error installing ruby-debug-ide19:

     ERROR: Failed to build gem native extension.  C:/Ruby/bin/ruby.exe extconf.rb checking for vm_core.h... *** extconf.rb failed *** Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers.  Check the mkmf.log file for more details.  You may need configuration options.  Provided configuration options:     --with-opt-dir     --without-opt-dir     --with-opt-include     --without-opt-include=${opt-dir}/include     --with-opt-lib     --without-opt-lib=${opt-dir}/lib     --with-make-prog     --without-make-prog     --srcdir=.     --curdir     --ruby=C:/Ruby/bin/ruby     --with-ruby-dir     --without-ruby-dir     --with-ruby-include     --without-ruby-include=${ruby-dir}/include     --with-ruby-lib     --without-ruby-lib=${ruby-dir}/lib C:/Ruby/lib/ruby/1.9.1/mkmf.rb:362:in `try_do': The complier failed to generate an executable file. (RuntimeError) You have to install development tools first.     from C:/Ruby/lib/ruby/1.9.1/mkmf.rb:431:in `try_cpp'     from C:/Ruby/lib/ruby/1.9.1/mkmf.rb:809:in `block in have_header'     from C:/Ruby/lib/ruby/1.9.1/mkmf.rb:668:in `block in checking_for'     from C:/Ruby/lib/ruby/1.9.1/mkmf.rb:274:in `block (2 levels) in postpone'     from C:/Ruby/lib/ruby/1.9.1/mkmf.rb:248:in `open'     from C:/Ruby/lib/ruby/1.9.1/mkmf.rb:274:in `block in postpone'     from C:/Ruby/lib/ruby/1.9.1/mkmf.rb:248:in `open'     from C:/Ruby/lib/ruby/1.9.1/mkmf.rb:270:in `postpone'     from C:/Ruby/lib/ruby/1.9.1/mkmf.rb:667:in `checking_for'     from C:/Ruby/lib/ruby/1.9.1/mkmf.rb:808:in `have_header'     from extconf.rb:15:in `block in <main>'     from C:/Ruby/lib/ruby/gems/1.9.1/gems/ruby_core_source-0.1.4/lib/ruby_core_source.rb:18:in `call'     from C:/Ruby/lib/ruby/gems/1.9.1/gems/ruby_core_source-0.1.4/lib/ruby_core_source.rb:18:in `create_makefile_with_core'     from extconf.rb:20:in `<main>'   Gem files will remain installed in C:/Ruby/lib/ruby/gems/1.9.1/gems/linecache19-0.5.11 for inspection. Results logged to C:/Ruby/lib/ruby/gems/1.9.1/gems/linecache19-0.5.11/ext/trace_nums/gem_make.out Building native extensions.  This could take a while...

0
Comment actions Permalink

Worked for me, thanks.

0

Please sign in to leave a comment.