Debugging in RubyMine 2.0 :: Can't install ruby-debug-ide19 on Windows

Hi Everyone,

I am brand new to RoR, and to RubyMine as well.  I am following along with this movie http://media.rubyonrails.org/video/rails_blog_2.mov and everything is working so far...

Until I got to the debugging step.  I can't seem to get ruby-debug-ide19 installed, from within RubyMine, or just from the console.

Can you please help me be able to debug with RubyMine?

I will happily share any further info.

Thank you much,
Mike

3 comments
Comment actions Permalink

Hi Michael,

you may use instruction from http://giorgio-ferrara.blogspot.com/2009/11/how-to-enable-ruby-debug-in-rubymine-20_22.html on how to install ruby-debug gem. There's some manual patching and additional software needed, so we can not fully automate this step.

0
Comment actions Permalink

Hi Dennis,

Thank you VERY much, that worked perfectly!

I am still unable to debug, but at least now it's because I simply don't know what I'm doing.  It looks like RubyMine is happy with everything and is certainly not crashing.

Can you please point me towards what I can learn to use the debugger well?

Very excellent and thank you again,

Mike

0
Comment actions Permalink

Hi Mike,

you may want to take a look at our debugger web page to start with: http://www.jetbrains.com/ruby/features/ruby_debugger.html and look for "Running and debugging" in our help topics (Help | Help Topics), there is a blog post http://blogs.jetbrains.com/ruby/2009/06/did-you-know-searching-for-help/ on how to use help search function

Develop with Pleasure! =)

0

Please sign in to leave a comment.