Getting RubyMine 2.0 to work with MacRuby .5 on Snow Leopard

Does any one know how to get the MacRuby SDK to work in RubyMine 2.0?

I have changed the Ruby SDK to the MacRuby interpreter but I get an error messge ( see attached)RubySDK and GEMS.tiff

Any help would be appreciated.

Thanks

1 comment
Comment actions Permalink

Hi Bruce,

It's due to macruby doesn't support "VERSION" constant which is recognized by MRI Ruby and JRuby. I've filed an issue - http://youtrack.jetbrains.net/issue/RUBY-5513. I suppose we can add some workaround for this.

0

Please sign in to leave a comment.