Unable to setup Ruby SDK info

Hi,

When I run RubyMine (2.0 beta3) and try to access the "Ruby SDK and Gems" project settings UI just flashes loading and never completes.  I noticed a red flashing exclamation point in status bar.  Clicking it showed the following error.

null
java.lang.NullPointerException
at org.jetbrains.plugins.ruby.settings.RubyIdeSdkConfigurable.reset(RubyIdeSdkConfigurable.java:35)
at com.intellij.openapi.options.newEditor.OptionsEditor.b(OptionsEditor.java:86)
at com.intellij.openapi.options.newEditor.OptionsEditor.access$2100(OptionsEditor.java:34)
at com.intellij.openapi.options.newEditor.OptionsEditor$6$1.run(OptionsEditor.java:3)
at com.intellij.openapi.application.impl.ApplicationImpl.runReadAction(ApplicationImpl.java:278)
at com.intellij.openapi.options.newEditor.OptionsEditor$6.run(OptionsEditor.java:2)
at com.intellij.openapi.application.impl.ApplicationImpl$6.run(ApplicationImpl.java:10)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:619)
at com.intellij.openapi.application.impl.ApplicationImpl$1$1.run(ApplicationImpl.java:5)

Anyone know what the heck this means.

If I open a project I can acess the "Ruby SDK and Gems" project settings page.

Thanx

jra

3 comments
Comment actions Permalink

Hi John,

It seems it some RubyMine bug, I've filled an issue - http://youtrack.jetbrains.net/issue/RUBY-5386. Does it still reproducible after RubyMine relaunching?

0
Comment actions Permalink

HI,

Yes it is happens every time. I've uninstalled and reinstalled and it still happens.  Platform is Win 7 64 bit.

I have another machine, win 7 64 bit, and I'm able to edit SDK settings.

Thanx

jra

0
Comment actions Permalink

We've fixed it, fix will be available in next RubyMine public build

0

Please sign in to leave a comment.