RubyMine 2.0 Spellchecker weirdness

I'm using Rubymine 2.0 on OSX 10.6.1.  I'm having a strange problem with the spellchecker: it seems to highlight method and variable names. For instance: screengrab.png
Why is it trying to correct the spelling for attr_accessor?  This didn't happen in RubyMine 1.1.1

9 comments
Comment actions Permalink

Hello Jesse,

I'm using Rubymine 2.0 on OSX 10.6.1.  I'm having a strange problem
with the spellchecker: it seems to highlight method and variable
names. For instance:  Image:screengrab.tiff  Why is it trying to
correct the spelling for attr_accessor?  This didn't happen in
RubyMine 1.1.1


The spellchecker does spell check method and variable names; this is by design.
However, we don't yet recognize all standard Ruby and Rails method names
as valid; this will be addressed in the final 2.0 release.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

I'd like to suggest that you guys add an option to turn off spell checking of method and variable names. For me, spell checking is useful for strings, but for methods and variables I'd prefer to name them whatever I choose without annoying suggestions.

0
Comment actions Permalink

This is hugely annoying.  

exception.backtrace is spelt wrong, really?

This could be the one thing that would make me NOT to buy this product, unless there is an easy way to turn the feature off completely.  

0
Comment actions Permalink

Hello guys,

If you see warning you can easily accept this word as correct in several clicks inside editor. Just put caret on warning and press Alt+Enter. Then select option Accept as corrrect.

Or you can easily turn off spellchecker at all in several ways:

  • Disable ruby-spellchecker plugin in RubyMine plugins manager File | Settings | Plugins.
  • Disable corresponding inspection in File | Settings | Inspections


We considerr adding some options to Ruby spellchecker to allow restrict inspection to literals, code etc.

Regards,
Oleg

0
Comment actions Permalink

Hi folks,

We have added following options to Spellchecker Typo inspection:
typo.png

Regards,
Oleg

0
Comment actions Permalink

This works - thanks.

0
Comment actions Permalink

How do you turn off the spell checker? I find this feature totally annoying and kinda useless.

0
Comment actions Permalink

As Oleg mentioned above:

Re: RubyMine 2.0 Spellchecker weirdness

Hello guys,

If you see warning you can easily accept this word as correct in several clicks inside editor. Just put caret on warning and press Alt+Enter. Then select option Accept as corrrect.

Or you can easily turn off spellchecker at all in several ways:

  • Disable ruby-spellchecker plugin in RubyMine plugins manager File | Settings | Plugins.
  • Disable corresponding inspection in File | Settings | Inspections


We considerr adding some options to Ruby spellchecker to allow restrict inspection to literals, code etc.

Regards,
Oleg

0
Comment actions Permalink

The forthcoming RubyMine versions would have reworked spellchecker plugin to make it more convenient to configure used dictionaries.

Regards,
Oleg

0

Please sign in to leave a comment.