Unusable after upgrading to #1421 (workaround included).

After upgrading to #1421, RubyMine was unusable.  I found a workaround and put my experience here in the hopes that it may help others (and RubyMine).

I am using Ubuntu Jaunty.

I updated to #1421 using, Help | Check for Update.  This downloads the latest version and shuts down RubyMine.

When I started up RubyMine, a dialog asked me if I wanted to install the patch.  Yes.

During this a warning dialog appeared.  It indicated "a problem exists" and asked me to choose a solution.  If memory serves, it listed the file ???/resources_en.jar, indicated the "problem" was "modified", and the possible solutions?  Ignore.  I chose "Ignore".  Franky, I wasn't sure why it was showing this to me, but I translated it to say that that the resources_en.jar file was modified and, since I was updating, that sounded reasonable to me.

As RubyMine was starting up, I received a standard RubyMine Error dialog, but it indicated that the error had occurred > 100 times.  2 of 2 was very simple, something like "Too many errors.  No longer monitoring."  I sent the error (as mmscili), but the dialog did not allow me to enter a description.

When RubyMine completed its startup, the UI was incomplete.  No menu, no tabs, partial view of an open file, no toolbars, no text in the title bar.  Pressing 'X' brought up an incomplete close dialog.

As I was writing this, my teammate performed the upgrade as well.  He had many more warnings (he thinks they all said modified and ignore).  When RubyMine finally opened, it was even worse than mine.  He had to leave shortly after, and did not get a chance to confirm this workaround.


After closing RubyMine.  I moved my existing copy, downloaded the latest EAP from http://www.jetbrains.net/confluence/display/RUBYDEV/RubyMine+EAP, and (tada) a working RubyMine!  It looks like all my settings were in the projects .idea folder, because I haven't found a missing setting yet.

Thanks for RubyMine.

Comment actions Permalink

Hello guys,

I'm using Ubuntu Jaunty 64b too. I had Previous EAP installed and tryied to update using Check for Updates option.
Everything worked pretty good in my case. Please ensure your RubyMine has enough permissions to modify itself.
In my case I had to run RubyMine with root privileges to obtain write permissions.


Comment actions Permalink

Hi Oleg,
I have similar problems with the upgrade patch and I'm on windoze. I did see a table of inconistencies, selected the defaults and proceeded. The patch seemed to run to completion. When RubyMine tried to restart it hung at the splash screen. There was no cpu activity, no error messages etc. And from then on that version of RubyMine was unusable, wouldn't start. I downloaded and installed the entire new version from scratch and installed it in a separate directory. That worked fine.

I had similar problems with using the patch on the last upgrade. I'll stick to the long way in the future, unless some kind of fix goes into the patch.

As usual thanks for the great tools.

Comment actions Permalink

Clarification:  The error occurred during update from 1364 to 1421.  The automatic update from 1347 to 1364 worked fine.

Comment actions Permalink

While this may have been my problem, my co-workers experience does not support this.

His experience:

During the 1421 patch install, a large list of "problems" was presented.  He chose "cancel", which proceeded to start RubyMine in the previous version (1364).  He shutdown and restarted using 'sudo rubymine'.   I assume that using 'sudo' would provide the necessary permissions.  The patch only listed a single warning this time (probably the same as mine?).  He selected the only available solution, "ignore", and continued, only to find an unusable RubyMine.

Installing rubymine in a fresh dir worked for him.


Please sign in to leave a comment.