HTTP Proxy Setting not working on Windows Rubymine 1.1.1 / 1.5-1287

I work in a Windows environment with internet access through a proxy server on port 8080

I have entered the proxy server adress and port in the settings dialog, but RubyMine doesn´t honor them - for example I can´t install any Gems through the Gem Manager.

Note: Netbeans 6.7 on the same system works fine...

Any ideas?

cu jc

4 comments
Comment actions Permalink

Hello Jens-Christian,

I work in a Windows environment with internet access through a proxy server on port 8080


I have entered the proxy server adress and port in the settings dialog, but RubyMine doesn´t honor them - for example I can´t install any Gems through the Gem Manager.


Note: Netbeans 6.7 on the same system works fine...

Indeed, RubyMine should use configured proxy setting for gem remote operations.
I've filled an issue: http://www.jetbrains.net/jira/browse/RUBY-4565
Feel free to vote and track progress of it.

Regards,
Oleg

0
Comment actions Permalink

Done and tracking progress...

also - in the same vain - I couldn't send crash reports through the tool (got an error message). Also here, Proxy settings were set correctly

0
Comment actions Permalink

Corresponding issue was fixed a while ago, fix will be available in RubyMine next EAP build coming soon.

0
Comment actions Permalink

great! Looking forward to the next version

cheers
jc

0

Please sign in to leave a comment.