Problem installing in existing directory?

I have attempted to install RubyMine updates in the asme directory without success.
The message asks for an empty directory or a directory with an existing installation of RubyMine 1.x

I have tried to install 1.1 over 1.05, and 1.1 Build 952 over 1.1 Build 933, and they both refuse to update the existing installation.

Installation directory is K:\Rubymine
The existing RubyMine installation works fine.

I am running Windows XP SP3 with all updates.

2 comments
Comment actions Permalink

Hello Garold,
RubyMine doesn't allow to install one version over another. Although in nearest future RubyMine will support automatic updates.

0
Comment actions Permalink

As for linux I have script /usr/local/bin/rubymine with content

export JDK_HOME=/opt/jdk1.6

cd /opt/rubymine949/bin

exec ./rubymine.sh



 

This configuration allow me easily change Java version and rubymine after update.
Not very much connected to your question, but may be helpful for others.

Regards,
Oleg

0

Please sign in to leave a comment.