7 comments
Comment actions Permalink

Hello,

1. Which version of RubyGems do you use?
2. Which OS do you use?

0
Comment actions Permalink

Sorry I forgot to write it:
Ruby 1.8 and 1.9
gem v.1.3.2
macosx 10.5

K

0
Comment actions Permalink

Ok, which interpreter is selected as SDK in RubyMine's Sdk and Gem Manager settings? '/usr/bin/ruby' or '/opt/local/bin/ruby' ?

Ruby 1.8 and 1.9
gem v.1.3.2

Where interpreters for ruby 1.8 and 1.9 are located on your disk? Please execute command 'which ruby' and 'which gem'

0
Comment actions Permalink

ruby:
/opt/local/bin/ruby
gem:
/opt/local/bin/gem

thanks for trying to solve it.

K

0
Comment actions Permalink

which interpreter is selected as SDK in RubyMine's Sdk and Gem Manager settings? '/usr/bin/ruby' or '/opt/local/bin/ruby' ?

Please answer on this question too =) It is important.
(RubyMine | Settings | RubySDK and Gem Manager | Ruby Interpreter combobox)

0
Comment actions Permalink

OK I think I start to see the problem:
I have two configurations;
for 1.8; /usr/bin/ruby1.8
for 1.9: /usr/bin/ruby1.9

best

K

0
Comment actions Permalink

for 1.8; /usr/bin/ruby1.8

If /usr/bin/ruby1.8 points on default MacOS ruby bundle (/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby) RubyMine will use it's gem, e.g. /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/gem. RubyMine 1.1 needs rubygems >= 1.3 otherwise RubyMine will not see installed gems. I suppose in your case RubyMine uses bundled in MacOS ruby 1.8.6 with old version of rubygems.

0

Please sign in to leave a comment.