How may I unselect Use DRb Server for RSpec runner in RubyMine 1.1?

Hi, I just downloaded (and purchased a license for) RubyMine 1.1.  I decided to purchase the license because I saw that 1.1 contained a bug fix allowing RSpec tests to be run individually without the DRb server (running with the DRb server produces problems for me). However, I now find that the Use DRb Server option in the Edit Configuration for RSpec is disabled and CHECKED.  Therefore, I cannot unselect it, and when I try to run the individual test I get the error "No server is running".  How may I edit this configuration to stop using the DRb server?

Thanks,
Matt Morris

2 comments
Comment actions Permalink

OK, I figured out a hack that seems to work:

  • Start the DRb server
  • Edit Configurations and unselect Use DRb Server - the checkbox is enabled when the server is running.
  • Kill the DRb server (I need to use Activity Monitor to kill it since RubyMine doesn't seem to shut it down correctly)
  • Run the RSpec test without DRb.
0
Comment actions Permalink

Hello Matt,

Unfortunately your are right. Our fix works for new configurations and doesn't fix existing configurations. Please recreate that configuration. If Drb server isn't running new configuration will be created with unselected "use drb" option also during editing configuration settings checkbox will be disabled.

0

Please sign in to leave a comment.