10 comments
Comment actions Permalink

Hello David,

I get no response

What do you mean? You enabled Git in VCS Settings of RubyMine and nothing happened or RM show error that wasn't able to connect to git repository?

I would like to enable Git support.


Also your use case isn't clear for me. I have two ideas:

1. You have got existing sources that are already under Git version control (e.g. you got them by cloning some existing git repository). By some reason RM doesn't
understand that your project is under Git, so you manually enabled it in Settings | Version Control | Directory: <Project Root>, VCS: Git

2. You have got project that isn't under version control. Thus you want to add it to VCS. So you thought that enabling VCS support in RM's settings would automatically
create new git repository and push sources.

0
Comment actions Permalink

Sorry for lack of info.

Since upgrading to #883 or maybe #873 or before I no longer have Git support in RubyMine (I have CVS and SVN).

In settings -> plugins I see CSS, CVS, SVN and Performance Integration plugins enabled (in black) and the rest including Git Integration in red. Checking Git causes the pluging manager status message to indicate trying to access http://plugins.jetbrains.com/ruby and that's as far as it goes - this message just stays there and the progress bar runs.

I'm running Ubuntu 8.10 and can use git for the project from the command line successfully.

Many thanks
David

0
Comment actions Permalink

Hello David,

plugin manager status message to indicate trying to access http://plugins.jetbrains.com/ruby

Yes it's know issue and doesn't related to Git plugin. Please read my answer in thread http://www.jetbrains.net/devnet/thread/281490?tstart=0

Since upgrading to #883 or maybe #873 or before I no longer have Git support in RubyMine (I have CVS and SVN).


In settings -> plugins I see CSS, CVS, SVN and Performance Integration plugins enabled (in black) and the rest including Git Integration in red



I've just check fresh RubyMine 1.0 installation on Ubuntu - git is enabled. May your problem is due to some old settings from previous RM EAP builds.

1. Please take screenshot of installed plugins list in RubyMine's plugin manager.
2. Close RubyMine
3. Backup ~/.RubyMine10 folder and then delete it
4. Launch RubyMine and check list of Plugins in RubyMine's plugin manager

0
Comment actions Permalink

I did as you instructed but still no joy.See screenshot.

Thanks.



Attachment(s):
rubymine-plugin-manager-git-red.png
0
Comment actions Permalink

David,

I have no idea what's happened. We will investigate it.

Please track http://www.jetbrains.net/jira/browse/RUBY-4000 issue status

0
Comment actions Permalink

Hello David,

Please make sure that you don't unpack one build of RubyMine over another
one, and instead install every build in a clean directory. We sometimes repackage
stuff or add/remove libraries, and installing builds over one another can
cause things like duplicate plugins which are shown on your screenshot.

I did as you instructed but still no joy.See screenshot.

Thanks.

---
Original message URL:
http://www.jetbrains.net/devnet/message/5237621#5237621

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Just to follow up - I have installed #907 in a new directory and still have the same issue. Not the end of the world - I don't mind using the command line.

0
Comment actions Permalink

Dmitry

Out of interest I have just install Ubunti 9.10 on a fresh machine and insalled RubyMine. I get the message "plugin is incompaitible with current Intellij IDEA installation" when I hover over the git plugin in the plugin manager. I also get this on the other machine but didn't notice it before.

Does this offer any clue why it's not working on either machine? Is it sometjhing to do with the version of git ( 1.6.2.4) installed on the machine?

David

0
Comment actions Permalink

Hello David,

Out of interest I have just install Ubunti 9.10 on a fresh machine and
insalled RubyMine. I get the message "plugin is incompaitible with
current Intellij IDEA installation" when I hover over the git plugin
in the plugin manager. I also get this on the other machine but didn't
notice it before.

Does this offer any clue why it's not working on either machine? Is it
sometjhing to do with the version of git ( 1.6.2.4) installed on the
machine?


The git version doesn't affect the plugin compatibility check in any way.

How do you run RubyMine? You may get this error if you aren't using rubymine.sh
from the latest build of RubyMine.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Dmitry

Yes, to my shame I copied the rubymine.sh from a previous insall as I had made a couple of mods but I  didn't diff first.

Many thanks and well spotted.

David

0

Please sign in to leave a comment.