Can't select different Rails Versions on new project

How do I select one of the other gem versions I have installed when creating a new project?  The only option is 1.2.6, even though I've installed gems for 2.0.2, 2.3.2, etc. as well?

I tried the Gem/SDK page of the settings.

Thanks,

Brian

2 comments
Comment actions Permalink

Hi Brian,

Which OS do you use? MacOS? I think RubyMine autodetected  bundled ruby 1.8.6 installation:

/usr/bin/ruby@ -> ../../System/Library/Frameworks/Ruby.framework/Versions/Current/usr/bin/ruby


I suppose that you manually installed ruby 1.8.7(e.g. using macports in /opt/local/bin/ruby) and rails 2.3.2 gem is installed in ruby 1.8.7. Please run "which ruby" in console.

So you should add ruby 1.8.7 sdk:
1. Open File | Settings | Ruby Sdk and Gems
2. Press "Add sdk..." button and choose path to right ruby interpreter.
3. Press apply.
4. Also you can remove /usr/bin/ruby sdk. Now all should work.

0
Comment actions Permalink

Thanks!  This fixed it, and yes, I am using OS X.

Brian

0

Please sign in to leave a comment.