How to set the gem path so it sees system deps

/usr/local/lib/ruby/gems/1.8
is my local path, but rubymine in my home dir is not catching it. How can I set this?

5 comments
Comment actions Permalink

Hello Sean,

/usr/local/lib/ruby/gems/1.8

is my local path, but rubymine in my home dir is not catching it. How can I set this?

Could you please execute 2 commands:

which ruby

which gem
And post result here?

Regards,
Oleg

0
Comment actions Permalink

lepton:~ seanskye$ which ruby
/usr/local/bin/ruby
lepton:~ seanskye$ which gem
/usr/local/bin/gem  

or better yet

lepton:~ seanskye$ gem environment
RubyGems Environment:
   - RUBYGEMS VERSION: 1.3.1
   - RUBY VERSION: 1.8.7 (2008-08-11 patchlevel 72) [i686-darwin9.6.0]
   - INSTALLATION DIRECTORY: /usr/local/lib/ruby/gems/1.8
   - RUBY EXECUTABLE: /usr/local/bin/ruby
   - EXECUTABLE DIRECTORY: /usr/local/bin
   - RUBYGEMS PLATFORMS:
     - ruby
     - x86-darwin-9
   - GEM PATHS:
      - /usr/local/lib/ruby/gems/1.8
      - /Users/seanskye/.gem/ruby/1.8
   - GEM CONFIGURATION:
      - :update_sources => true
      - :verbose => true
      - :benchmark => false
      - :backtrace => false
      - :bulk_threshold => 1000
      - :sources => ["http://gems.rubyforge.org/", "http://gems.github.com"]
   - REMOTE SOURCES:
      - http://gems.rubyforge.org/
      - http://gems.github.com


and for good measure:

lepton:~ seanskye$ gem list --local

*** LOCAL GEMS ***

actionmailer (2.2.2)
actionpack (2.2.2)
activerecord (2.2.2)
activeresource (2.2.2)
activesupport (2.2.2)
ambition (0.5.4)
builder (2.1.2)
calendar_date_select (1.15)
capistrano (2.5.5)
columnize (0.3.0)
facets (2.5.0)
GData (0.0.4)
highline (1.5.0)
hoe (1.8.3)
hpricot (0.8.1)
linecache (0.43)
mime-types (1.15)
mislav-will_paginate (2.3.8)
multipart (0.2)
multipart-post (0.1)
mysql (2.7)
net-scp (1.0.2)
net-sftp (2.0.2)
net-ssh (2.0.11)
net-ssh-gateway (1.0.1)
newgem (1.2.3)
parseexcel (0.5.2)
ParseTree (3.0.3, 2.1.1)
prawn (0.4.1)
prawn-layout (0.1.0)
rails (2.2.2)
rake (0.8.4, 0.8.3)
RedCloth (4.1.1)
roo (1.2.3)
rspec (1.1.12)
rubigen (1.5.2, 1.1.1)
ruby-debug (0.10.3)
ruby-debug-base (0.10.3)
ruby-fedora (0.9.0)
ruby2ruby (1.1.8)
rubyforge (1.0.3, 1.0.2)
RubyInline (3.8.1)
rubyzip (0.9.1)
sexp_processor (3.0.1)
syntax (1.0.0)
will_paginate (2.2.2)
wirble (0.1.2)
xml-simple (1.0.11)
ZenTest (3.11.1)


but rubymine still says i don't have the gems installed in my project....

0
Comment actions Permalink

Hello Sean,

Lets ask RubyMine to recreate Ruby SDK settings:
1. File | Settings | RubySDK and Gems, press Remove SDK button
2. press "Apply" button
3. press "Add SDK.." button and select path to your ruby interpreter
4. press "Apply"
5. press "Attach Gems..." button. Then RM should show you local gems (the same list as in output of "gems list" command)

Also please show output of command


ruby -e "require 'rubygems'; puts Gem.path"



0
Comment actions Permalink

Cool. That works. So, perhaps it would be nice to be able to get what the ide thinks is the equiv of gem local --list and gem environment....

thanks
now to see how your ide stacks

0
Comment actions Permalink

Sean,

Thanks for the suggestion, I agree that displaying Gem environment information may be useful in RM. I've filled an issue http://www.jetbrains.net/jira/browse/RUBY-3944.

0

Please sign in to leave a comment.