Rspec 1.2

Hi all,

RSpec 1.2 was jsut released, which is now Rails 2.3 compatible.

Unfortunately the RubyMine Rake Runner won't accept it. It says not compatible with this version of Rspec.

Here's hoping for the ability to run Rspec 1.2 soon.

Thanks,

Andrew

6 comments
Comment actions Permalink

Hi Andrew,

Thanks for the suggestion and the issue http://www.jetbrains.net/jira/browse/RUBY-3297 we will update our RSpec support soon

0
Comment actions Permalink

Roman

I get this error

dump_summary': TeamCity Rake Runner Plugin isn't compatible with this RSpec version. (Rake::TeamCity::InnerException)
Error: Not all examples have been run! (0 of 7)

with other versions of RSpec too 1.1.12 and 1.1.14.

also connot run a single spec file from the command line e.g.

ruby scec/models/user_spec.rb

it just returns with no output - I don't think this is related to RubyMine - could it be?

David

0
Comment actions Permalink

For now, I got things to work again just by uninstalling RSpec and installing the 1.12 version...and it looks like they have a change request to support the current RSpec version.

0
Comment actions Permalink

Hi guys,

In  version 1.2 rspec team changed behavior of tests results reporting. It seems that it is a bug, I wrote about the problem to rspec-devel@rubyforge.org mailing list. At first I want to discuss new behavior with rspec team and than we will fix this in RubyMine.

Update: See issue http://rspec.lighthouseapp.com/projects/5645-rspec/tickets/738

0
Comment actions Permalink

Thanks Roman.

You guys are the best.

Andrew

0
Comment actions Permalink

Andrew,

Thanks =). We've fixed basic support for 1.2.0 (your issue http://www.jetbrains.net/jira/browse/RUBY-3297) and the fix will be available soon in next RubyMine EAP. Navigation to source from examples names in tests tree still is broken for RSpec 1.2.0. You may watch the status of issue http://www.jetbrains.net/jira/browse/RUBY-3341

0

Please sign in to leave a comment.