JRuby gems lib not parsed for autocompletion

Hello,

My environment is Fedora Linux, Java 1.6, IntelliJ 8.1 with Ruby plugin

I have installed JRuby 1.1.3 directly with fedora. This works perfectly and the gems are found and autocompletion in 'requite (...)' or in the code works.
In addition I have installed JRuby 1.1.6 manually and put it in a subdirectory. I configured it as JDK and it works, I can run a mixed JRuby, Java application but the autocompletion is not working. In the module area of the project structure, I can see that the lib is marked with a question marked but the JDK configuration seems to be fine.

I have attached Screen shots from all dialogs.

Do you have any idea why it is not working?

Best Regards

Sebastian



Attachment(s):
jruby-error-in-dependency-tab.png
jruby-1.1.6.png
jruby-1.1.3.png
3 comments
Comment actions Permalink

Hello Sebastian,

My environment is Fedora Linux, Java 1.6, IntelliJ 8.1 with Ruby plugin


I have installed JRuby 1.1.3 directly with fedora. This works perfectly and the gems are found and autocompletion in 'requite (...)' or in the code works.
In addition I have installed JRuby 1.1.6 manually and put it in a subdirectory. I configured it as JDK and it works, I can run a mixed JRuby, Java application but the autocompletion is not working. In the module area of the project structure, I can see that the lib is marked with a question marked but the JDK configuration seems to be fine.

I`ve created corresponding issue: http://www.jetbrains.net/jira/browse/RUBY-2639
Feel free to vote, comment and track progress of it.

Thanks,
Oleg

0
Comment actions Permalink

Workaround

In the project structure -> Platform Settings -> JDK->click on the JRuby JDK provided by the system (which is correctly parsing)

Change the 'Ruby interpreter path' of the JRuby SDK provided by your operation system to the path of the manually installed other version of JRuby

0

Please sign in to leave a comment.