Plugin 2.0 and ObjectSpace issue

I'm trying to run the new plugin with jruby in debug mode and I keep getting the following:

C:/dev/jruby-1.1.4/lib/ruby/gems/1.8/gems/activesupport-2.1.1/lib/active_support/dependencies.rb:513:in `require': ObjectSpace is disabled; each_object will only work with Class, pass +O to enable (RuntimeError)
from C:/dev/jruby-1.1.4/lib/ruby/gems/1.8/gems/rails-2.1.1/lib/commands/server.rb:39
from C:/dev/jruby-1.1.4/lib/ruby/gems/1.8/gems/rails-2.1.1/lib/commands/server.rb:27:in `require'
from C:/dev/jruby-1.1.4/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
from C:/project/script/server:3
from C:/project/script/server:96:in `main'
from C:/dev/jruby-1.1.4/lib/ruby/gems/1.8/gems/ruby-debug-ide-0.3.0/bin/rdebug-ide:74
from C:/dev/jruby-1.1.4/lib/ruby/gems/1.8/gems/ruby-debug-ide-0.3.0/bin/rdebug-ide:19:in `load'
from C:/dev/jruby-1.1.4/bin/rdebug-ide:19

When I run from command line I need to run jruby -X+O script/server (though when I run script/console I don't need the -X-O argument)

I tried to add the -XO and -J-XO but I can't get it to work either way.
Is there anything I'm missing? Does anyone know why I need to add the -O argument all of a sudden (I upgraded to from rails 2.0 and jruby 1.1 to work better with the plugin, so the problem may have to do with that)

I'm using plugin 2.0.208452, IDEA 8858, rails 2.1.1, jruby 1.1.4 and jdk1-6-07



Please sign in to leave a comment.