Missing File Commands in Ruby Plugins

So far two important file level commands are missing:

1. Compare Two Files
- When I tried to select two ruby files and right click in an attempt to compare the files, but the "Compare Two Files" menu is missing.

2. When I tried to add a ruby script (a ruby module) to SVN via right click, the corresponding menu is missing.

Hope we can see those menu back soon.

8 comments
Comment actions Permalink

Hello!
What version of plugin and IDEA do you use?
Works fine for me with IDEA#7718 and Ruby plugin v1.0.699.

0
Comment actions Permalink

Where did you right click? (in TextEditor/Project View tree/Rails Project View, etc)

0
Comment actions Permalink

I was using IDEA build 7590 and Ruby plugin 1.0.14330.

After updating to Ruby plugin 1.0.14699, the issues still exists.

Where can I get the versions of IDEA and Ruby plugin you mentioned? They are not available online.

0
Comment actions Permalink

I right-clicked from the Project View Tree.

0
Comment actions Permalink

7718 is one of 7.0.3 EAP builds.
Latest EAP builds can be downloaded at:
http://www.jetbrains.net/confluence/display/IDEADEV/Selena+EAP

0
Comment actions Permalink

Edmond, I've just checked it on 7590 and last EAP - all works.

1. This menus may be missed in Project View, if

  • ->[Ruby on Rails]->[Project View]->[Use Ruby specific Class/Module Project View] is enabled

  • in Rails Project View.

Please check it.

2. Also please right-click in IDEA text editor and check that Subversion submenu is shown. Check that your project is under version control. (see ->[version control])

0
Comment actions Permalink

Thanks Oleg. I'll wait for the next offical release to try that out.

0
Comment actions Permalink

Hi Roman,

I just tried with IDEA build 7757 and I follow your suggestions. Still cannot see the menus in tree view.

I can see the subversion menu when I right click the text editor.

0

Please sign in to leave a comment.