Plugin Run Configuration doesn't work after moving to new computer with new username

I recently moved to a new computer and now the Plugin Run Configuration for my Elixir plugin no longer works inside the test/debug instance of IntelliJ IDEA.  I don't get any messages in the log why the plugin isn't loaded.  I was able to build the plugin and then install the plugin from disk using the .zip, but that isn't ideal since I can't debug it then.  If it matters, my username changed from luke.imhoff to limhoff on the new computer.  I used Migration Assistent to move the files from the old computer and then moved /Users/luke.imhoff to /Users/limhoff from a secondary admin account.  Could this be a permissions issue, like a missed chown?  All the paths that I can see in the IDEA project seem to have just adjusted without any interaction from me.

2 comments
Comment actions Permalink

Have you checked correctness of sand box home in plugin sdk location?

On 10/11/2015 6:43 AM, Luke Imhoff wrote:

I recently moved to a new computer and now the Plugin Run Configuration for my Elixir plugin no longer works inside the test/debug instance of IntelliJ IDEA.  I don't get any messages in the log why the plugin isn't loaded.  I was able to build the plugin and then install the plugin from disk using the .zip, but that isn't ideal since I can't debug it then.  If it matters, my username changed from luke.imhoff to limhoff on the new computer.  I used Migration Assistent to move the files from the old computer and then moved /Users/luke.imhoff to /Users/limhoff from a secondary admin account.  Could this be a permissions issue, like a missed chown?  All the paths that I can see in the IDEA project seem to have just adjusted without any interaction from me.

>

---
Original message URL: https://devnet.jetbrains.com/message/5560346#5560346

>

0
Comment actions Permalink

The Sandox Home (/Users/limhoff/Library/Caches/IdeaIC14/plugins-sandbox) seems correct.  Since I first posted, I tried debugging again: after installing the zip, Debug is aware of source changes only in my project directories and not in the installed zip, so somewhere installing the plugin once through the zip made it able to see changes in the source *shrug*

0

Please sign in to leave a comment.