activate JavaFX Syntax

I have installed IntelliJ with JavaFX and android. I Can use the JavaFX commands, so, if I run it, it compiles and the Gui opens. But in the Sourcecode, JavaFX is completely disabled and it says: Cannot resolve Symbol JavaFX. I dont know why, but it runs annyway. The JDK is 1.8.0_25.
The file C:\Program Files\Java\jdk1.8.0_25\jre\lib\ext\jfxrt.jar is known in the Settings and the JavaFX Plugin is enabled. Does anyone of you have an idea, how I can change this?

With best Regards, Kanashius.

PS:If I posted in the wrong Section, please move it :)



Attachment(s):
intelliJJavaFXProblem.png
2 comments
Comment actions Permalink

Looks like that JDK is not setup correctly. Could you please check File|Project Settings. Thanks

0
Comment actions Permalink

Yes, that was the Problem. Whyever the JDK switched to Android, so the javafx was not avaible. Because I was running it at my PC it seems to work. I changed the Settings and now it works, thanks :)

0

Please sign in to leave a comment.