Weblogic integration

I'm trying to get weblogic10.3  running within intellij 8.1 on windows.

It's almost there, but when I restart the server it:

1. starts weblogic
2. weblogic starts all of its deployed apps
3. presumably intellij then deploys my app
4. the app then starts again

So, if I need to re-start the application server during development (i.e. I define a new spring bean), I have to wait for my application to start twice.

Is this the only way I can use weblogic with Intellij? Are there any other options?

Thanks.

6 comments
Comment actions Permalink

Do you deploy your application only from IDEA or you by using WebLogic admin console too?

I'm trying to get weblogic10.3 running within intellij 8.1 on windows.

It's almost there, but when I restart the server it:

1. starts weblogic
2. weblogic starts all of its deployed apps
3. presumably intellij then deploys my app
4. the app then starts again

So, if I need to re-start the application server during development (i.e. I define a new spring bean), I have to wait for my application to start twice.

Is this the only way I can use weblogic with Intellij? Are there any other options?

Thanks.

---
Original message URL: http://www.jetbrains.net/devnet/message/5236926#5236926



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

I only want to deploy it via Intellij.
Thanks.

0
Comment actions Permalink

Did you try to remove all deployed applications by using WebLogic console before starting WebLogic from IDEA?

I only want to deploy it via Intellij.
Thanks.

---
Original message URL: http://www.jetbrains.net/devnet/message/5237404#5237404



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

I ahve an application running under admin consoile already with Weblogic 10.3. I am trying to integrate weblogic 10.3 with that of Intellij 8.1. When add the Application server the classes added by the weblogic 10.3 are BEA_home/bea_10_3/wlserver_10.3\server \lib\api.jar and weblogic jar . It throws a warning saying that

Warning:Class javax.servlet.Servlet not found in application server. The above jar files are picked up by the intellij 8.1.  Do I need to add any other additional jar files related to javax to application server Library? If so what is it ? Since it is throwing this warning when I deploy applications through Intellij I also have the javax.servlet.Servletexception and servlets don't compile. But the application itself runs fine from the admin console. I would appreciate some detailed guidance as to how to eliminate this error and also some instructions as  to deploy the application through the intellij. My goal is that  what ever working application is running through admin console should work through the intellij.

Thanks for your reply and help

Kalpana

0
Comment actions Permalink

Could you try to add javaee.jar to "Modules and libraries to Package" tree
in your web facet settings? It could be the simpliest workaround.


0
Comment actions Permalink

In WebLogic 10.3, the javax.servlet.*, javax.servlet.jsp.*, and javax.ejb.* classes are in three jar files in <weblogic install directory>/modules. They are included in the manifest classpath of api.jar, but intellij doesn't appear to take the manifest classpath into account. You have to add the three jars highlighted below to resolve the errors.
intellij_weblogic_libraries.png

0

Please sign in to leave a comment.