Check in dialog prevents editing of comment

Whenever I check in changes to the source repository, I'm unable to edit the check in comment.  I can type highlight (with my mouse) the previous comment that's displayed by default, then overwrite it, but there's no other editing I can do.  I can't backspace, copy, paste, move my arrow key via keyboard, etc.  All I can do is: highlight text with my mouse, and type new text.

Has anyone else seen this behavior?

I first experienced it when I used the TFS plugin from 8.1 EAP with the 8.0.1 release.  Now I'm on 8.1 release, and this problem is still there.  I've tried the new Git plugin and it has the same symptoms when I check in a change.

2 comments
Comment actions Permalink

Hello Hubert,

Which OS are you on?

The checkin dialog is shared IDEA functionality and works the same regardless
of which VCS plugin you're using.

Whenever I check in changes to the source repository, I'm unable to
edit the check in comment. I can type highlight (with my mouse) the
previous comment that's displayed by default, then overwrite it, but
there's no other editing I can do. I can't backspace, copy, paste,
move my arrow key via keyb

oard, etc. All I can do is: highlight text with my mouse, and type
new text.

Has anyone else seen this behavior?

I first experienced it when I used the TFS plugin from 8.1 EAP with
the 8.0.1 release. Now I'm on 8.1 release, and this problem is still
there. I've tried the new Git plugin and it has the same symptoms
when I check in a change.

---
Original message URL:
http://www.jetbrains.net/devnet/message/5233789#5233789

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

I'm on Win XP SP2.

When I was in IDEA 7.x, I used the VSS plugin, and also the 3rd party TFS plugin from Codeplex, and did not have this issue.

By the time I switched to 8.0, we were already on TFS.  I tried using the Codeplex TFS plugin but it wasn't working properly, so I stopped using it.

When the TFS plugin became available via the 8.1 EAP, I started using it with 8.0.1, and that's when I first experienced this problem (Dec. 4, 2008).  It's behaved this way since then.

0

Please sign in to leave a comment.