Proguard-plugin for IDEA 8

Is anybody using able to analyze stacktraces deobfuscated with the
Proguard-plugin in IDEA 8? Although I have the "Proguard Unscramble Plugin"
installed, when I show click "Analyze|Analyze Stacktrace" the upper part of
the occurring dialog is grayed and I'm not able to select "Proguard" in the
"Unscrambler" combobox.

Tom

6 comments
Comment actions Permalink

Is no one else using the Proguard-plugin?

Tom

0
Comment actions Permalink

Still no feed-back?

Tom

0
Comment actions Permalink

All ProGuard users are also Opera users and hence cannot post their answers...


RRS

0
Comment actions Permalink

I've taken a look at the source code which was attached to the plug-in, but
this compiles fine in IDEA 8.

Question to the IDEA developers: what else could the proguard plug-in
prevent from showing up in the Analyze Stacktrace dialog?

Tom

0
Comment actions Permalink

Hello Tom,

I've taken a look at the source code which was attached to the
plug-in, but this compiles fine in IDEA 8.

Question to the IDEA developers: what else could the proguard plug-in
prevent from showing up in the Analyze Stacktrace dialog?


The implementations of UnscrambleSupport need to be registered via the ]]>
extension point, rather than via an application component.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

BTW, I've tried to fix the plugin according to the information from the
zkm-plug-in, but it did not work. We'll keep IDEA 7.0.4 for bug fixes until
Jetbrains (who are responsible for the API changes) fixes such plug-ins.

Tom

0

Please sign in to leave a comment.