TeamCity plugin hanging on Remote Run (and other problems)

We are using Idea 8 (9013), TeamCity Pro 3.0.1 (6010), and TC Plugin 2.1.05

Since the upgrade to Idea 8 from M1, the Remote Runs have been broken.
At first, it was only that committing following a remote run would fail because Idea couldn't find the changelist.
Now it starts dumping threads endlessly in the logs directory as soon as I try to start a remote run (I attached a file as an example).

I uninstalled and reinstalled the plugin without success (receiving an error on 1st reinstall that the plugin was not compatible w TC6010 after which I assume it downgraded the plugin to one that was).

Remote Run was working in M1.
Any ideas?

(I realize that upgrading TC would be the ideal solution but it's not an immediate option for us)



Attachment(s):
threadDump-20081113-113114.txt
4 comments
Comment actions Permalink

Hello Andy,

Are you using the plugin from http://www.jetbrains.net/confluence/display/TW/Diana-compatiblepluginforTeamCity3.1.x
?

If not, you should. :)

We are using Idea 8 (9013), TeamCity Pro 3.0.1 (6010), and TC Plugin
2.1.05

Since the upgrade to Idea 8 from M1, the Remote Runs have been broken.

At first, it was only that committing following a remote run would
fail because Idea couldn't find the changelist.

Now it starts dumping threads endlessly in the logs directory as soon
as I try to start a remote run (I attached a file as an example).

I uninstalled and reinstalled the plugin without success (receiving an
error on 1st reinstall that the plugin was not compatible w TC6010
after which I assume it downgraded the plugin to one that was).

Remote Run was working in M1. Any ideas?

(I realize that upgrading TC would be the ideal solution but it's not
an immediate option for us)

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

I upgraded to that plugin and I still see the same hang with thread dump behavior.
(no word yet from my team if they're no longer having the changelist commit problem)

Is there a way to determine if there's a bad plugin interaction (without having to turn them all off and add them back one at a time)?
Or some other debugging I can do to provide useful info?

0
Comment actions Permalink

I think I may have figured this out - the TeamCity plugin appears to depend on the CVS plugin (according to availables.xml), which I didn't have installed because we only use Subversion. I filed a question from the TeamCity site to follow-up on this.

0
Comment actions Permalink

I had the same problem with hanging remote run and subversion.

After re-enabling CVS plugin it works like gold!!!

Thank you for this post!:)

Piotr Gabryanczyk

0

Please sign in to leave a comment.