Idea8: recompiling plugin on jdk5?

How can I recompile plugin on jdk5 - for mac users? On my windows, when I want to add new "Intellij IDEA SDK", I can only choose java 1.6 (althought have all previous java versions)?

I can manually create SDK by removing 1.6 libs and adding 1.5 libs.

Is there any better method, or reason why not to do that?

3 comments
Comment actions Permalink

Intellij IDEA SDK uses "normal" JAVA JDKs as base, so you probably have no "normal" JAVA 1.5 JDK defined to choose from?

0
Comment actions Permalink

I do have jdk's from 4 up to 6, but somehow, idea8 just shows jdk6 in combo box.

but i guess if i manually choose replace the jdk, the effect would be the same.

0
Comment actions Permalink

Hello Igor,

How can I recompile plugin on jdk5 - for mac users? On my windows,
when I want to add new "Intellij IDEA SDK", I can only choose java
1.6 (althought have all previous java versions)?

I can manually create SDK by removing 1.6 libs and adding 1.5 libs.

Is there any better method, or reason why not to do that?


See http://www.jetbrains.net/confluence/display/IDEADEV/BuildingPluginswithIntelliJIDEA7.0and+8.0
for instructions. :)

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Please sign in to leave a comment.