Remove scala plugin from 8.0M1

Hi, I installed the scala plugin on 8.0M1 on windows. Now when I start IDEA I get an error message that says:

Plugin org.intellij.scala failed to initialize:
com.intellij.codeInsight.completion.CompletionVariant.addCompletionFilterOnElement(Lcom/intellij/psi/filters/ElementFilter;)V
Please remove the plugin and restart IntelliJ IDEA

Maybe there is more text on the second line, I can't tell.

How can I remove the plugin? I have deleted the scala folder in the IntelliJ IDEA 8.0M1\plugins directory but it still gives me the above error.

edit: And on the topic, what is the state of scala for 7.0.4? I installed the 0.1 plugin and while I can create .scala files I cannot compile them. It tells me to setup the scala sdk. I have installed scala but I'm not sure where or how to point IDEA to the sdk? For example with groovy I would go to settings -> Project Settings -> Modules -> and then add the groovy facet and point it to the groovy dk. But I can't find an equivalent option with scala?

edit2 for images:




Edited by: fostandy on Sep 21, 2008 12:18 PM

Edited by: fostandy on Sep 21, 2008 12:45 PM

1 comment
Comment actions Permalink

I had the same problem.

You need to delete the "Scala" directory from:

Documents and Settings\your_user\.IntelliJIdea80\config\plugins

0

Please sign in to leave a comment.