JBoss Integration Oddities

In the last week or so, a strange issue appeared on my desktop instance of IntelliJ 7.0.3. When attempting to execute JBoss 4.2.2 as a run configuration, I receive a message "Error running JBoss 4.2.2 Local: Address localhost:1099 is already in use".

I have seen this many times in the past, and always corrected it by going to a cmd prompt and running netstat -anb to see which other pid is holding port 1099, and killing it. Unfortunately this time, netstat is not showing any other process holding on to 1099. To further complicate the matter, I am able to execute the run.bat script to start JBoss from the command prompt without issue.

I am running on Vista Ultimate 32, with the most recent JDK 6. I have tried completely removing and reinstalling IntelliJ, JBoss, and my JDK with no changes. I have also tried rolling back to JDK5 and creating an empty project with only the jboss run configuration (no make, ant, or maven 'before launch' tasks - start only).

Has anyone experienced anything similar or have any suggestions?

Thanks!

2 comments
Comment actions Permalink

The only thing coming to my mind is that your local firewall could block access to port 1099.

0
Comment actions Permalink

Problem solved.

NOD32 Antivirus appears to, by default treat java and intellij installations as 'Internet Browsers' and apply protocol filtering. I am filing a support request with ESET to see if this behavior can be modified somewhat to prevent the odd symptoms I described.

0

Please sign in to leave a comment.