[ANN] Struts 2 plugin 0.1

The first alpha version is out (IDEA 7.0.2 EAP Build #7549) and can be downloaded via plugin manager.

Please see the plugin documentation page at http://www.jetbrains.net/confluence/display/CONTEST/Struts2Plugin for a full overview and change notes.

Please post your bug reports, feature requests and other comments in this thread or contact me directly via email if you want to join the development (sources will be made available soon).

Greetings,

Yann

7 comments

Hi Yann,

Will your plugin also support Webwork?
We could update our project to Struts 2 but it would be tough to sell this idea to the management (update it just for having a plugin working :))
Struts 2 is generally compatible with Webwork.

Adam

0

Hello Adam,

AFAIK that would just require the plugin to recognize the "old" WW2-config files with their corresponding DTD-IDs. I will give this a try and include this functionality if possible.

Thanks for your suggestion,

Yann

0

Hello,

Thanks for plugin! :)

Some troubles (try to Fix via downloading libraries):


Message was edited by:
Alexey Efimov

0

Hello Alexey,

thanks for the info.

I doubt this exception originates from my plugin but I will take a look at it.

Greetings,

Yann

0
Avatar
Nikolay Chashnikov

It's IDEA bug. It will be fixed in next EAP build.

Hello,

Thanks for plugin! :)

Some troubles:
@NotNull method com/intellij/facet/ui/libraries/LibraryDownloadInfo.getPresentableUrl must not return null > java.lang.IllegalStateException: @NotNull method com/intellij/facet/ui/libraries/LibraryDownloadInfo.getPresentableUrl must not return null > at com.intellij.facet.ui.libraries.LibraryDownloadInfo.getPresentableUrl(LibraryDownloadInfo.java) > at com.intellij.facet.impl.ui.libraries.LibraryDownloadingMirrorsMap.getPresentableUrl(LibraryDownloadingMirrorsMap.java:26) > at com.intellij.facet.impl.ui.libraries.LibraryDownloader.a(LibraryDownloader.java:155) > at com.intellij.facet.impl.ui.libraries.LibraryDownloader.access$200(LibraryDownloader.java:23) > at com.intellij.facet.impl.ui.libraries.LibraryDownloader$1.run(LibraryDownloader.java:2) > at com.intellij.openapi.progress.impl.ProgressManagerImpl$2.run(ProgressManagerImpl.java:9) > at com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessUnderProgress(ProgressManagerImpl.java:31) > at com.intellij.openapi.progress.impl.ProgressManagerImpl.runProcess(ProgressManagerImpl.java:84) > at com.intellij.openapi.application.impl.ApplicationImpl$7$1.run(ApplicationImpl.java:4) > at com.intellij.openapi.application.impl.ApplicationImpl$5.run(ApplicationImpl.java:2) > at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441) > at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303) > at java.util.concurrent.FutureTask.run(FutureTask.java:138) > at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885) > at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907) > at java.lang.Thread.run(Thread.java:619) > at com.intellij.openapi.application.impl.ApplicationImpl$1$1.run(ApplicationImpl.java:4) > > ]]>



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

Support for xwork-2.0.dtd-configuration files will be available in next version (see http://www.jetbrains.net/jira/browse/STRPL-9)

0

Please sign in to leave a comment.