Plugin installed but not available - Resolved

Hi,

I'm new to developing plugins for IntelliJ applications so please forgive me if I'm asking a stupid question. I've written a plugin that provides a new Run Configuration.

  • When I run the plugin from within IDEA for testing, either an instance of IDEA or PyCharm starts depending on the SDK I've set:
    • I can go to the to top right of the screen, select edit Configuration from the drop down
    • Then I can click the + button, see my new Configuration, select it, provide some details and click apply/save.
    • I can then (ensuring its selected in the drop down) click the Run button and the Plugin does as I expect.

  • However if I choose 'Prepare Plugin Module <> for Deployment in the Build Menu:
    • I get a new Jar file.
    • I have tried loading this jar file into IDEA and PyCharm using the 'Install Plugin from Disk' option
    • The plugin looks to install correctly and I can see it in the list of installed Plugins as being installed and active.
    • I then restart the IDE as per instruction
    • Once restarted if I again go to the top right of the screen, and Edit Configurations
    • However when I click the + button this time my plugin is not listed.
    • Going back to the Plugin dialog it shows me that the plugin is load.


Anyone have any ideas what I'm doing wrong? As I've said I've tested it IntelliJ IDEA and Pycharm by running the plugin code via the IDE, and everything works as expected. I'm getting no errors about the plugin either during install or starting the IDEs.

Thanks,

Mark

5 comments
Comment actions Permalink

Can you check if there are any exceptions in idea.log? There's an action in the Help menu that navigates to the log in the OS file manager.

0
Comment actions Permalink

Ah, I was trying to find some application logs. Thanks for that tip, when I get a chance I'll have a look and see if I can see anything.

Mark

0
Comment actions Permalink

Hi Dmitry,

Looks like I've found the problem in the log file, I'm getting a Unsupported major.minor version 51.0 exception being thrown, though I'm a bit confused as to why.

I'm running a mac using Yosemite, and my default Java is java version "1.8.0_05".
The plugin is being developed in the latest vesion of IntelliJ Idea with my SDK for the project using jdk1.7.0_60.jdk.

While looking in the logs I can see the following message:

2014-12-22 17:55:41,962 [   5895]  ERROR - nsions.impl.ExtensionPointImpl - IntelliJ IDEA 14.0.2  Build #IC-139.659.2
2014-12-22 17:55:41,962 [   5895]  ERROR - nsions.impl.ExtensionPointImpl - JDK: 1.6.0_65
2014-12-22 17:55:41,962 [   5895]  ERROR - nsions.impl.ExtensionPointImpl - VM: Java HotSpot(TM) 64-Bit Server VM

I don't even think I have 1.6 installed on this machine anymore so I'm not sure why it would try and reference it.

What version of Java are the IDEs built against? As I've said the plugin are working when launching an IDE in development mode.

Are the IntelliJ IDEs being developed against an older Java SDK? Do I need to be building the plugin using 1.6?

Thanks for your help,

Mark

0
Comment actions Permalink

IntelliJ IDEA currently runs under JDK 1.6 under Mac OS X by default. Therefore, you need to build your plugin with JDK 1.6 too.

0
Comment actions Permalink

That fixed it,

Thanks.

0

Please sign in to leave a comment.