How to upload different plugin versions for different SDK versions?

Since Jetbrains changed API in latest version I need to upload two versions of my plugin:

v1 for old IDEs (IDEA 13)
v2 for new IDEs (IDEA 14)

How can I do it?

5 comments
Comment actions Permalink

Set the since-build and until-build attributes in your plugin.xml according to the IntelliJ IDEA versions that the plugin is compatible with. The plugin manager will automatically download the version which is compatible with the build the user is running.

0
Comment actions Permalink

Thanks. Pls answer one more related question. Suppose you changed an API. How can I get `since-build` for new API?

Here is real example - I'm using NonProjectFileWritingAccessExtension.java.

1. I found NonProjectFileWritingAccessExtension.java on github.com
2. Checked history - https://github.com/JetBrains/intellij-community/commits/ff16ce78a1e0ddb6e67fd1dbc6e6a597e20d483a/platform/platform-impl/src/com/intellij/openapi/fileEditor/impl/NonProjectFileWritingAccessExtension.java
3. Detected ticket -  IDEA-125277
4. Opened this ticket in youtrack - https://youtrack.jetbrains.com/issue/IDEA-125277#tab=Comments
5. Checked "Fixed in builds" field

So to use NonProjectFileWritingAccessExtension.java I have to specify since-build = 138.1225. Is it correct? Were my actions correct?

0
Comment actions Permalink

This is correct but unnecessarily precise. All published EAP builds of IntelliJ IDEA from the 138 branch are time-limited and have expired by now; you only care about the release branch. So you might just as well set the since-build to 139.1.

0
Comment actions Permalink

Hm... can I skip until-build param?

Suppose I've got two versions:

v1 since-build="133"
v2 since-build="139"

If I use IDEA 13 v1 will be downloaded. If I use IDEA 14 v2 will be downloaded. Is it correct? So can I skip until-build param?

0
Comment actions Permalink

If I remember correctly you do need to set the until-build for the first plugin.


0

Please sign in to leave a comment.