InvocationTargetException/NoClassDefFoundError while running a plugin

I have an issue -- when I run a sample code from within the intellij , it runs just fine but when I run it as a plugin (all the correct libraries/dependencies are provides in the plugin module's classpath) I get an exception (see below):

50812] ERROR - com.intellij.ide.IdeEventQueue - Error during dispatching of java.awt.event.MouseEvent[MOUSE_RELEASED,(39,7),button=1,modifiers=Button1,clickCount=1] on ###overrideRedirect###
java.lang.RuntimeException: java.lang.reflect.InvocationTargetException
at com.vasoftware.sf.soap43.webservices.ClientSoapStubFactory.getSoapStub(ClientSoapStubFactory.java:57)
at com.gs.fw.odyssey.sfee.SfourgeCheckinAction.actionPerformed(SfourgeCheckinAction.java:49)
at com.intellij.openapi.actionSystem.impl.ActionMenuItem$ActionTransmitter.actionPerformed(ActionMenuItem.java:13)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1849)
at com.intellij.openapi.actionSystem.impl.ActionMenuItem.fireActionPerformed(ActionMenuItem.java:44)


Is it a classloader issue on an eventdispatch thread ?

1 comment
Comment actions Permalink

Any insight/answer will be much appreciated.

0

Please sign in to leave a comment.