Struts Assistant--Web Flow Diagram Exceptions?

Ok, I re-installed IDEA 6.0.1 and I can now open my Struts config files againbut the Web Flow Diagram is blank (this is an existing project, in production, there are plenty of mappings) and the following exception seems to be caused by swithing to "Web Flow Diagram" view once my struts-config is opennote that the tab opens, there are grid dots but no flows or other components:


Regards
Patrick

2006-11-07 11:58:40,640 ERROR - ij.components.ComponentManager - IntelliJ IDEA 6.0.1 Build #5784
2006-11-07 11:58:40,640 ERROR - ij.components.ComponentManager - JDK: 1.5.0_08
2006-11-07 11:58:40,640 ERROR - ij.components.ComponentManager - VM: Java HotSpot(TM) Client VM
2006-11-07 11:58:40,640 ERROR - ij.components.ComponentManager - Vendor: Sun Microsystems Inc.
2006-11-07 11:58:40,640 ERROR - ij.components.ComponentManager - OS: Windows XP
2006-11-07 11:58:40,640 ERROR - ij.components.ComponentManager - Last Action: Graph.FitContent
2006-11-07 11:58:40,640 ERROR - ij.components.ComponentManager - Current Command: Save settings
2006-11-07 11:58:40,781 INFO - project.impl.ConfigurationFile - Time to save D:\Work\GameDuell\checkout\head-uc-split\GameDuell HEAD UC SPLIT.iws: 63
2006-11-07 11:58:44,828 INFO - lij.localVcs.impl.LocalVcsImpl - purged 0 items
2006-11-07 11:58:44,875 ERROR - ij.components.ComponentManager -
java.lang.NoClassDefFoundError: org/springframework/util/Assert
at com.yanaware.intellij.ideaspring.config.PluginConfigurableImpl.writeExternal(SourceFile:281)
at com.intellij.openapi.components.impl.ComponentManagerImpl.serializeComponent(ComponentManagerImpl.java:94)
at com.intellij.openapi.project.impl.BaseFileConfigurable.saveToXml(BaseFileConfigurable.java:118)
at com.intellij.openapi.project.impl.BaseFileConfigurable._save(BaseFileConfigurable.java:107)
at com.intellij.openapi.project.impl.ProjectImpl$3.run(ProjectImpl.java:3)
at com.intellij.openapi.command.impl.CommandProcessorImpl.executeCommand(CommandProcessorImpl.java:67)
at com.intellij.openapi.command.impl.CommandProcessorImpl.executeCommand(CommandProcessorImpl.java:65)
at com.intellij.openapi.project.impl.ProjectImpl.save(ProjectImpl.java:73)
at com.intellij.ide.SaveAndSyncHandler.b(SaveAndSyncHandler.java:36)
at com.intellij.ide.SaveAndSyncHandler.access$200(SaveAndSyncHandler.java:31)
at com.intellij.ide.SaveAndSyncHandler$3.onFrameDeactivated(SaveAndSyncHandler.java:6)
at com.intellij.ide.FrameStateManagerImpl.a(FrameStateManagerImpl.java:28)
at com.intellij.ide.FrameStateManagerImpl.access$100(FrameStateManagerImpl.java:39)
at com.intellij.ide.FrameStateManagerImpl$1.run(FrameStateManagerImpl.java:2)
at com.intellij.util.Alarm$1.run(Alarm.java:106)
at com.intellij.util.Alarm$MyThread$1.run(Alarm.java:250)
at com.intellij.openapi.application.impl.LaterInvocator$FlushQueue.run(LaterInvocator.java:6)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
at com.intellij.ide.IdeEventQueue.defaultDispatchEvent(IdeEventQueue.java:163)
at com.intellij.ide.IdeEventQueue.a(IdeEventQueue.java:8)
at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:145)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

6 comments

Do you have IdeaSpring plugin installed? Try removing it.

0

I had IdeaSpring installed until this afternoon (just so happens--before I saw your message). It was causing other exceptions (reported in the IDE, unlike the one from this thread), so I removed it. Struts Assistant is no longer causing exceptions when switching to web flow diagram, so I'll assume that fixed it. Still don't have diagrams, either, but that's the next thing on the list.

Thanks
Patrick

0

Yes, no diagram = blank screen for web flows. I think the project is not properly configured, I'm working with a team that has a fairly extensive Struts/Tiles/Spring setup, but I'm not sure if their directory structure matches what is expected. From my struts config files, I can navigate to Java classes, but path references to JSPs and tiles configuration don't work. So the problems might be in the way I set up the project.

Maybe I should start another thread, but here's the basic layout

/a-project
../top
..../src
....../resources (properties)
....../java (beans, forms, actions, other)
....../webapp
........./tiles
........./other-jsp
........./WEB-INF
.........../classes
.........../lib

There are others, but that's the basics. The struts-config is in WEB-INF, JSPs are either in /webapp or subdirectories. Tiles-config is in /webapp/tiles.

I've tried configuring this in IDEA in several different ways, with mixed results. This is the first time I've tried using IDEA for a web app. There is an IDEA project, and this part of the project is configured as a web module, with root at /webapp.

src/java, src/resources and src/webapp are all configured as content roots, so that I can open them via ctrl-shift-n, and src/resources is also in the dependency list, so that it gets packed to webapp/WEB-INF/classes on make.

There is one deployment descriptor, /WEB-INF/web.xml, and webapp is listed as a web resource, with path of "/".

I really have no idea what I'm doing, but I can compile and deploy the module's Java code and properties, and run it (externally). That much is good--but in general it feels like a mess. I don't know if this is because I just don't understand what IDEA is expecting, or if the team is using a non-standard layout (they all work with Eclipse on Linux, I'm using IDEA on Windows; among other things, they use quite a lot of symlinks to ease certain deployment).

So--improper setup may be the cause of my struts woes, but I haven't found the documentation that useful.

Any tips appreciated!
Patrick

0

Could you please report exceptions you've got caused by IdeaSpring ? Which version do you use ?

Thank You

0

I will post the exceptions on a separate thread.

0

Please sign in to leave a comment.