Struts assistant cannot resolve anything in struts-config.xml

I working on a fairly large J2EE Open Source project and could really use the Struts-assistant but can't seem to get it happn.

I've tried pointing the project libraries and global libraries to every .jar in the project (7) but it doesn't seem to make any diff. Every single reference is bright red in struts-config with the Cannot resolve class message.

Except the org. is green on all of them....

What am I doing wrong?

Thanks,

Sam

6 comments
Comment actions Permalink

To verify your project setup is correct: do you get autocompletion of said classes in normal JAVA-code?

0
Comment actions Permalink

Hi Sam,

your project/global libraries should be added to classpath of your web
module. Are they?

"Sam Loy" <sampaw@mac.com> wrote in message
news:8554793.1160144919726.JavaMail.itn@is.intellij.net...
>I working on a fairly large J2EE Open Source project and could really use
>the Struts-assistant but can't seem to get it happn.
>

I've tried pointing the project libraries and global libraries to every
.jar in the project (7) but it doesn't seem to make any diff. Every single
reference is bright red in struts-config with the Cannot resolve class
message.

>

Except the org. is green on all of them....

>

What am I doing wrong?

>

Thanks,

>

Sam



0
Comment actions Permalink

Sorry for the long delay....

I have gone thru and reset the project from the beginning. Everything compiles and the JSPs are all good...no unresolves (except a few property keys which I also don't understand :().

I am very confident my depencies are set up properly cuz I added one module at a time, making sure everything compiled before moving on. Do I need to add my .tld files as a resource somewhere?

Also, I can't get the thing to stop at any of my breakpoints...well most of my breakpoints...

Is there a thread/reference that would help understand the relationship between the compile classes and source? Where does the debugger look to map the VM Instruction Ptr to a Source File?

I know its just the Newbie blues...

Thanks for any help you can offer. I'll gladly send you anything that might help or share it on my server...just let me know...

Thanks!

Sam
Texas

0
Comment actions Permalink

The project has multiple Web and Java modules and a J2EE Module. There are a total of 5 struts-config.xmls in the project, each in thier own little Web Module.

I don't get it...the STruts assistant is completely useless and all three windows are blank. I turned on struts tiles and validation support when I created the modules but get nada....

Can anyone ask me something or help me through this? I am really getting beyond frustration...It's an open source project and using an ant build, cuz it wont build anyway else ...at least not package the ear file the way it's packaged by the ant build...which I'm not even sure is necessary.

It is very difficult cuz I have only a cursory understanding of struts and j2ee. I methodically re-create the entire project about 17 times now. Each time I add a module, I get it to compile, starting with the core. As I add modules it continiues to build. In fact it was all building fine until 6.01, now one of the modules fails on the build because it cannot resolve symbols in another module - which is and was a dependency of the module failing. That module builds fine...

Now whats REALLY perplexing is when I double click the error in the messages pane, and the file is brought up on screen with the cursor at the offending line ...and guess what? ITS NOT RED. It does n't show an error. When a re-validate it - it validates fine...only when I make....

I feel like I have about a zillion problems and don't know which are my mis understandings or maybe just bugs in IDEA.

God have mercy...

I will gladly PAY someone to get me properly set up and configured. I much as I hate eclipse, I may have to resort to it. This is an eclipse project and I have a feeling that's why is so UNNESSARILY complicated. I know enough to know it doesn't have to be this complex.

0
Comment actions Permalink

Sam - Did you ever hear back on this issue? I'm in the same spot, multiple web modules, each with its own struts-config.xml. In my case, Struts Assistant sees the first struts-config.xml file I created but can't see anything else. Likewise, when I'm configuring my JSPs with struts config aware tags like html:form the action paths don't resolve.

If you've heard anything or found a solution on your own please let me know. If you haven't heard anything from jetbrains let me know that too, it could be an indication that this is a problem that the tool can't cope with.

Thanks!

0
Comment actions Permalink

Please upgrade to 6.0.2, SA definitely supports multiple web modules each having multiple struts-config.xml files. Probably just a little quirk in your project setup..

0

Please sign in to leave a comment.