Optional dependency for python

After a long trial/error (and multiple plugin releases ) I have come to the conclusion that in order to enable an extension both in PyCharm and in the Python plugins I have to specify the following three lines in the plugin.xml file:

    <depends optional="true" config-file="python-ext.xml">PythonCore</depends> <!-- Python plugin CE -->
    <depends optional="true" config-file="python-ext.xml">Pythonid</depends> <!-- Python plugin -->
    <depends optional="true" config-file="python-ext.xml">com.intellij.modules.python</depends> <!-- PyCharm -->


Am I doing the right thing?
Is there somewhere a list of all the PluginId supported by the various products/plugins?
Are this PluginIds remaining stable or I should expect them to change?

2 comments

Hey,

it looks like that the behaviour has changed and now the Python plugin CE also triggers the dependency using the pluginId:

com.intellij.modules.python

Is my statement correct?

I noticed this because with the former config file now loads the python-ext.xml twice in Idea CE...

Can I now assume that that pluginId triggers the dependency for Python plugin, Python plugin CE and PyCharm?

 

0

Please sign in to leave a comment.