Intellij plugin not compatible with appcode

Hello there,

I am currently working on a plugin : http://plugins.jetbrains.com/plugin/7400?pr=objc

The plugin gets the github accounts settings of the user and fetches his gists.
It is very simple and depends only on the github plugin :

<idea-plugin version="2">
...
   <depends>com.intellij.modules.lang</depends>    <depends>org.jetbrains.plugins.github</depends>
</idea-plugin>


So I thought it might work with any of the JetBrains IDEs which includes github plugin, like appcode.

But when I start debugging it with appcode as a JDK, I get the following message:

2014-03-11 22:17:14,947 [   1484]   INFO - llij.ide.plugins.PluginManager - Disabled plugins: Gist Templates (0.11)

I have no idea why, I cannot figure out how to debug it since the sources of the PluginManager seem to differ from idea community.

Any leads on that error or an idea on how I could effectively debug it ?

2 comments
Comment actions Permalink

I don't know why it's happening but if you want to debug it, first step would be to remove the github dependency from the plugin.xml requirements and see if it still gets disabled.
That's where I'd start from.

0
Comment actions Permalink

Thank you for your answer.
Turns out I switched SDK from idea to appcode without changing the sandbox folder which somehow messed everything up.

0

Please sign in to leave a comment.