JProbe Plugin

I have been playing with JProbe, and was excited to find that it ships with an IntelliJ plugin. However, it was written for 3.x. Since I can't give up my Aurora features =), I am interested in trying to get it to work with the EAP's.

When I started up Aurora with the jprobe jar in the plugins directory, there were no exceptions thrown and next to the run/debug buttons were the 4 JProbe icons. (see screenshot). However, when I click any of the buttons, nothing happens. No exceptions, no programs starting, nothing. I'm wondering if there is some change that can be made to the plugin.xml to get it to work with Aurora. Is there anyone out there who would know what the relevant changes might have to be? Thanks. I'll post here as well if I figure out anything.

Tobin



Attachment(s):
icons.bmp
plugin.xml
7 comments
Comment actions Permalink

didn't eugene work on jprobe or at least the company that developed it?

0
Comment actions Permalink

JProbe was developed by Sitraka (now part of Quest). I worked for
TogetherSoft (now part of Borland).

Eugene


"charles decroes" <spam@decroes.com> wrote in message
news:6759081.1058579944238.JavaMail.itn@is.intellij.net...

didn't eugene work on jprobe or at least the company that developed it?



0
Comment actions Permalink

Tobin Juday wrote:

I have been playing with JProbe, and was excited to find that it ships with an IntelliJ plugin. However, it was written for 3.x. Since I can't give up my Aurora features =), I am interested in trying to get it to work with the EAP's.


Yes, the plugin was written for and tested with IDEA 3.0. I've spoken
with the developer who wrote it and he says he'll try get it working
with the latest EAP version (873).

Ciao,
Gordon

--
Gordon Tyler (Software Developer)
Quest Software <http://java.quest.com/>
260 King Street East, Toronto, Ontario M5A 4L5, Canada
Voice: 416-643-4846 | Fax: 416-594-1919

0
Comment actions Permalink

Whoa, awesome. Is the developer an IDEA user? I thought about writing them and asking them to update their plugin, but then I figured that they wouldn't want to be constantly be changing it for the EAP. But anyways, I'm glad you've got that inside connection. Thanks for asking!

Tobin

0
Comment actions Permalink

Tobin Juday wrote:

Whoa, awesome. Is the developer an IDEA user?


I'm not sure how much he uses IDEA. We do have quite a few licenses and
I would estimate that most of our developers use IDEA on a partial if
not full-time basis. Most use the 3.0 version though. I think I'm the
only one brave enough to use the EAP version ;)

I thought about writing them and asking them to update their plugin, but then I figured that they wouldn't want to be constantly be changing it for the EAP.


The work will have to be scheduled along with the other work he's doing
so I can't make any promises about when it will be done or how quickly
it could be updated for incompatible changes in the EAP.

But anyways, I'm glad you've got that inside connection. Thanks for asking!


Glad to help.

Ciao,
Gordon

--
Gordon Tyler (Software Developer)
Quest Software <http://java.quest.com/>
260 King Street East, Toronto, Ontario M5A 4L5, Canada
Voice: 416-643-4846 | Fax: 416-594-1919

0
Comment actions Permalink

I've put up a plugin that can launch the DevPartner profiler
(performance,coverage,memory,deadlocks) from within IntelliJ.

It works with 856 and 3.0.4. I haven't tried it with 873 yet.

http://www.intellij.org/twiki/bin/view/Main/DevPartnerPlugin

Regards,
Paul

0
Comment actions Permalink

I've installed the JProbe 6.0.1 plugin for IDEA 4.x intp IDEA 5.1.2. The buttons appear on the toolbar but nothing happens when I click them. Any support planned for an IDEA 5.x compatible plugin?

0

Please sign in to leave a comment.