Struts Assistant - Problems

Hi!

I'm trying Struts Assistant and I have a some issues I could use some help on.
In the Create JSP wizard, when I browse for a path, and select it, it creates a new hierarchy under the WEB-INF folder. Example:
/WEB-INF/WEB-INF/pages/...
Am I missing something?

Another issue, that could be related to the afore mentioned, is that the Diagram view does not reflect the html:link forwards in the JSPs. Even though they're declared in global-forwards. Shouldn't it?

It's quite probable that these are just the product of my ignorance, so I thank in advance for any help.

I'm using Struts Assistant 1.20 and IDEA 5.0.1 #3461

Thanks.

P.S.: A tutorial or some kind of more detailed docs than the ones provided would be really useful.

2 comments
Comment actions Permalink

Hi,

what path are you entering in the wizard? and how your WEB-INF is mapped in the web module settings?
As for <html:link> displaying on the diagram, it is not implemented yet, but may be a good suggestion for future.

0
Comment actions Permalink

Hey.
I've created a Web module, and the path is:
E:\Program Files\Apache Software Foundation\Tomcat 5.5\webapps\lcbet-struts\
\WEB-INF
-\src
--\java
---\app
--\pages
..etc

It's rather possible that I didn't create the module as it was supposed. Anyway, if I entered in the path something like:

"/WEB-INF/pages/page.jsp"

then the folders would be like this:
\WEB-INF
-\src
--\java
---\app
--\pages
*-\WEB-INF
--\pages
---page.jsp*
etc..

I've tried to create the JSPs in the project view, but it didn't solved the problem. I'm sure theres some kind of misunderstanding, but I cna't really figure it out.
By the way, I installed the plug-in manually, not through IDEA. I couldn't connect from within it.
Thanks again! And yep, showing <html:link> would be really great.

Message was edited by:
hjrnunes

Message was edited by:
hjrnunes

0

Please sign in to leave a comment.