XPathViewer doesn't work in last builds

In IDEA log files I found the following exception:

java.lang.NoClassDefFoundError: org/apache/crimson/tree/XmlDocument
at org.intellij.plugins.xpathView.util.MyPsiUtil.isValidContextNode(MyPsiUtil.java:35)
...

It seems IDEA doesn't include crimson since some release.
It would be very useful to get it fixed, because it greatly simplifies xsl development.

Thanks in advance,
Pavel

2 comments

This is actually a bug in the plugin that refers to crimson's XmlDocument instead of IDEA's one. However, the build that is being offered by the Plugin Manager for Demetra is totally outdated and there won't be an updated Demetra-compatible version in the near future. You could probably work around this though by putting a jar that contains the requested class in the plugin's lib folder without any ill effects.

Sascha

0

Hello Sascha,

Thanks for quick answer, will try to add jar from one of previous versions.

Regards, Pavel

0

Please sign in to leave a comment.