Cannot find JDK 'IDEA jdk' for module 'xslt-rt'

Hi,

When I compile and run the latest code of IDEA, I get this error:

java: Cannot find JDK 'IDEA jdk' for module 'xslt-rt'

I followed instructions from README.md and did this steps:

  • Downloaded and installed idea-IC 130.1619 (Cardea)
  • Downloaded and installed JDK 6
  • Added new SDK 'JDK6'
  • Added new SDK 'IDEA jdk', pointing to JDK6 + tools.jar
  • Checked out the latest source code from github
  • Opened the project from Intellij Cardea
  • Launched the provided 'IDEA' run configuration

Then I get the mentioned error.

I tried these steps on Windows 7 and Ubuntu with the same result.

I've checked the modules, they all use project SDK which is 'IDEA jdk'.
When I change xslt-rt module SDK to 'IDEA jdk', the error is gone, but the similar error appears for other module.
Also (I'm not sure whether it's related or not) there are circular dependencies between modules.


So the question is: Is it bug in Cardea, or it's a project misconfiguration? Have I missed something?



Attachment(s):
modules.png
error.png
2 comments

Are you sure 'IDEA jdk' is a regular Java SDK and not a plugin SDK?

0

Yes, that was the cause. Thank you!

0

Please sign in to leave a comment.